Bug 188126 - X segfaults on scaled images in seamonkey (cairo-gtk2)
X segfaults on scaled images in seamonkey (cairo-gtk2)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
http://wp.netscape.com/fishcam/fishca...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 05:24 EDT by Ferdinand
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 16:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log with backtrace (55.32 KB, application/octet-stream)
2006-04-06 05:33 EDT, Ferdinand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 6827 None None None Never

  None (edit)
Description Ferdinand 2006-04-06 05:24:23 EDT
Description of problem:
X crashed when I opened the large feed of
http://wp.netscape.com/fishcam/fishcam.html in a cairo-gtk2 test build of
seamonkey. The bug didn't show when I tried to reproduce it.


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.0.1-9

How reproducible:
Not (yet) reproduced

Steps to Reproduce:
1. Browse around with cairo-gtk2 enabled mozilla.
2. Go to URL
3. Open Large Feed

Actual results:
X may crash

Additional info:

Xorg.0.log.old had this backtrace:
0: /usr/bin/Xorg(xf86SigHandler+0x87) [0x80b86c7]
1: [0x497420]
2: /usr/lib/xorg/modules/libfb.so [0x2715d1]
3: /usr/lib/xorg/modules/libfb.so [0x27784e]
4: /usr/lib/xorg/modules/libfb.so(fbCompositeGeneral+0x855) [0x275505]
5: /usr/lib/xorg/modules/libfb.so(fbComposite+0x1cd) [0x27fdbd]
6: /usr/lib/xorg/modules/libxaa.so(XAAComposite+0x261) [0x2d5261]
7: /usr/bin/Xorg [0x81543e6]
8: /usr/bin/Xorg(CompositePicture+0xf7) [0x8142007]
9: /usr/bin/Xorg [0x8147d6c]
10: /usr/bin/Xorg [0x81450a5]
11: /usr/bin/Xorg(Dispatch+0x19b) [0x80888eb]
12: /usr/bin/Xorg(main+0x487) [0x80701d7]
13: /lib/libc.so.6(__libc_start_main+0xdc) [0x1167e4]
14: /usr/bin/Xorg(FontFileCompleteXLFD+0xb1) [0x806f511]

Fatal server error:
Caught signal 11.  Server aborting

Will installing xorg-x11-server-debuginfo help create a more useful backtrace
when/if it happens again?
Comment 1 Ferdinand 2006-04-06 05:33:12 EDT
Created attachment 127401 [details]
xorg log with backtrace
Comment 2 Ferdinand 2006-05-02 07:22:20 EDT
It did happen again today - so it's rather hard to reproduce.
It's caused by https://bugzilla.mozilla.org/show_bug.cgi?id=334951 and as
comment 9 there says, the browser seems to load random video memory sometimes.
That's obviously bad behaviour, but I don't think it should be able to crash X.
I've not been able to load the fishcam image for some time, but images resized
to fit the browser window do often show the broken behaviour. For example:
http://imgsrc.hubblesite.org/hu/db/2006/18/images/a/formats/web_print.jpg
Comment 4 Ferdinand 2006-10-24 15:05:00 EDT
This has apparently been fixed by the xorg team. (See external bug reference)
So this should be fixed in FC6, I guess.

This bug's also discussed in https://bugzilla.novell.com/show_bug.cgi?id=152730
Comment 5 Adam Jackson 2007-04-02 16:48:05 EDT
Per comment #4 and the upstream bug, this should be fixed in FC6.  Please reopen
if this issue reoccurs for you.

Note You need to log in before you can comment on or make changes to this bug.