Bug 1881306 - "Restore as a new PVC" action item is greyed out in snapshots
Summary: "Restore as a new PVC" action item is greyed out in snapshots
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Kanika Murarka
QA Contact: Neha Berry
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-22 07:10 UTC by Jilju Joy
Modified: 2020-10-27 16:43 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:43:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot showning 'Restore as a new PVC' item greyed out (143.20 KB, image/png)
2020-09-22 07:10 UTC, Jilju Joy
no flags Details
Screenshot showning 'Restore as a new PVC' item greyed out in kebab (161.58 KB, image/png)
2020-09-22 07:14 UTC, Jilju Joy
no flags Details
Screenshots for verification (268.75 KB, application/zip)
2020-09-24 20:07 UTC, Neha Berry
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6702 0 None closed Bug 1881306: Fixes Kebab action for snapshots 2020-10-23 14:37:42 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:43:58 UTC

Description Jilju Joy 2020-09-22 07:10:12 UTC
Created attachment 1715640 [details]
Screenshot showning 'Restore as a new PVC' item greyed out

Description of problem (please be detailed as possible and provide log
snippests):
Unable to restore snapshot from  UI because the action item "Restore as a new PVC" is greyed out. The reason is shown as  "Volume Snapshot is not Ready". But the snapshot is in Ready state.
There are no error events in the Volume Snapshot Details page.
Snapshot-restore is working from cli.


Version of all relevant components (if applicable):
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-09-22-000541   True        False         97m     Cluster version is 4.6.0-0.nightly-2020-09-22-000541

$ oc get csv
NAME                        DISPLAY                       VERSION       REPLACES   PHASE
ocs-operator.v4.6.0-90.ci   OpenShift Container Storage   4.6.0-90.ci              Succeeded

# ceph version
ceph version 14.2.8-91.el8cp (75b4845da7d469665bd48d1a49badcc3677bf5cd) nautilus (stable)



Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?
Yes. Cannot restore a snapshot from UI


Is there any workaround available to the best of your knowledge?
No
Tried reloading the page


Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?
1


Can this issue reproducible?
Yes


Can this issue reproduce from the UI?
Yes. Issue is in UI


If this is a regression, please provide more details to justify this:
Yes, the issue was not seen in previous nightly builds


Steps to Reproduce:
1. Create snapshot of a PVC from UI
2. When the snapshot is Ready, try to restore the snapshot from UI


Actual results:
"Restore as a new PVC" action item is greyed out.


Expected results:
Should be able to click on "Restore as a new PVC" action item and it will lead to a page where the new PVC details can be entered.



Additional info:

Comment 3 Jilju Joy 2020-09-22 07:14:01 UTC
Created attachment 1715643 [details]
Screenshot showning 'Restore as a new PVC' item greyed out in kebab

Comment 6 Neha Berry 2020-09-24 20:07:46 UTC
Created attachment 1716428 [details]
Screenshots for verification

Verified the fix in following build

OCP = 4.6.0-0.nightly-2020-09-24-111253

OCS = ocs-operator.v4.6.0-569.ci

The "Restore As  New PVC" option is available in both the pages:
1. Volume Snapshots Tech Preview-> Snap name -> 3 dots -> Restore as new PVC

2. Volume Snapshots Tech Preview-> Snapshot->-> Actions -> Restore as new PVC

_________________________________________________________



$ oc get pvc
NAME                         STATUS   VOLUME                                     CAPACITY   ACCESS MODES   STORAGECLASS                  AGE
rbd-pvc1                     Bound    pvc-d781a575-c898-41d1-9541-1d1ff7a25bd7   10Gi       RWO            ocs-storagecluster-ceph-rbd   26m
rbd-pvc1-snapshot-restore    Bound    pvc-94bf36e9-20f8-4bae-8bae-f909f8124be0   10Gi       RWO            rbd-default-pool              11m
rbd-pvc1-snapshot2-restore   Bound    pvc-4a524790-8d50-4704-b8f5-7b997e1333b3   10Gi       RWO            ocs-storagecluster-ceph-rbd   4m27s


$ oc get volumesnapshot
NAME                 READYTOUSE   SOURCEPVC   SOURCESNAPSHOTCONTENT   RESTORESIZE   SNAPSHOTCLASS                            SNAPSHOTCONTENT                                    CREATIONTIME   AGE
rbd-pvc1-snapshot    true         rbd-pvc1                            10Gi          ocs-storagecluster-rbdplugin-snapclass   snapcontent-8c0466b4-0da1-42b6-acd0-a03c6d106673   24m            25m
rbd-pvc1-snapshot2   true         rbd-pvc1                            10Gi          ocs-storagecluster-rbdplugin-snapclass   snapcontent-094d9356-3324-42f4-9ba1-62c80d7262ef   8m53s          8m54s


$ oc get pvc rbd-pvc1-snapshot-restore -o yaml|grep dataSource -A 7
--
  dataSource:
    apiGroup: snapshot.storage.k8s.io
    kind: VolumeSnapshot
    name: rbd-pvc1-snapshot
  resources:
    requests:
      storage: 10Gi
  storageClassName: rbd-default-pool
[nberry@localhost logs]$ 



$ oc get pvc rbd-pvc1-snapshot2-restore -o yaml|grep dataSource -A 7

--
  dataSource:
    apiGroup: snapshot.storage.k8s.io
    kind: VolumeSnapshot
    name: rbd-pvc1-snapshot2
  resources:
    requests:
      storage: 10Gi
  storageClassName: ocs-storagecluster-ceph-rbd


Parent volume

$ oc get pvc rbd-pvc1 -o yaml|grep dataSource -A 5
<no data>


__________________________________________________

+++
csi-snap-00b14484-fe9f-11ea-a0a2-0a580a800213
csi-snap-d8ba9f2d-fe9c-11ea-a0a2-0a580a800213
csi-vol-4aea1cc2-fe97-11ea-a0a2-0a580a800213
csi-vol-93fdd308-fe9c-11ea-a0a2-0a580a800213
csi-vol-97fd9e68-fe9e-11ea-a0a2-0a580a800213
csi-vol-a1bd3af8-fe9f-11ea-a0a2-0a580a800213

______________________________________

Step performed:

1 Created a parent PVC pvc rbd-pvc1 from UI

2. Created 2 snapshots of the PVC

3. Navigated to Volume Snapshots and clicked on Restore as a PVC under Actions Menu for the selected snapshot

4. The PVC is created.

Comment 9 errata-xmlrpc 2020-10-27 16:43:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.