Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1881341 - protobuf-3.12.3-1.eln103 fails to rebuild in ELN buildroot
Summary: protobuf-3.12.3-1.eln103 fails to rebuild in ELN buildroot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: protobuf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Igor Raits
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-22 08:37 UTC by Kamil Dudka
Modified: 2020-10-05 00:17 UTC (History)
8 users (show)

Fixed In Version: protobuf-3.12.4-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-05 00:17:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Dudka 2020-09-22 08:37:10 UTC
Version-Release number of selected component (if applicable):
protobuf-3.12.3-1.eln103


How reproducible:
Easily.


Steps to Reproduce:
1. koji buildinfo $(koji latest-build --quiet eln protobuf | cut -f1 -d' ') | grep ^Task
2. koji build --scratch eln git+https://src.fedoraproject.org/rpms/protobuf.git:9059bd58f0fc24232b5a2b1d918c404eb18f2af1


Actual results:
[...]
[ERROR] Errors: 
[ERROR]   ExtensionRegistryFactoryTest.initializationError ยป ExceptionInInitializer
[INFO] 
[ERROR] Tests run: 996, Failures: 0, Errors: 1, Skipped: 0
[INFO] 
[INFO] 
[INFO] ------------------------------------------------------------------------
[INFO] Skipping Protocol Buffers [Parent]
[INFO] This project has been banned from the build due to previous failures.
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary for Protocol Buffers [Parent] 3.12.3:
[INFO] 
[INFO] Protocol Buffers [BOM] ............................. SUCCESS [  0.005 s]
[INFO] Protocol Buffers [Parent] .......................... SUCCESS [  0.003 s]
[INFO] Protocol Buffers [Lite] ............................ SUCCESS [06:18 min]
[INFO] Protocol Buffers [Core] ............................ FAILURE [08:16 min]
[INFO] Protocol Buffers [Util] ............................ SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  14:35 min
[INFO] Finished at: 2020-09-22T08:29:30Z
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.22.0:test (default-test) on project protobuf-java: There are test failures.
[ERROR] 
[ERROR] Please refer to /builddir/build/BUILD/protobuf-3.12.3/java/core/target/surefire-reports for the individual test results.
[ERROR] Please refer to dump files (if any exist) [date]-jvmRun[N].dump, [date].dumpstream and [date]-jvmRun[N].dumpstream.
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
[ERROR] 
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <args> -rf :protobuf-java
error: Bad exit status from /var/tmp/rpm-tmp.rrRblv (%build)


Expected results:
Successful build.


Additional info:
scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=52003502

Comment 2 Kalev Lember 2020-10-02 08:47:35 UTC
I see that it's fixed in rawhide now with the update to 3.13.0, but the F33 version is still FTBFS. This is blocking various flatpak builds; would be nice to get the F33 build fixed as well.

Comment 3 Kalev Lember 2020-10-02 09:03:08 UTC
OK, I tracked down the fix in 3.13.0: upstream has just disabled the failing test. I'll go and backport this to F33 so that we can get the FTBFS fixed.

Comment 4 Kamil Dudka 2020-10-02 09:38:24 UTC
It would be also good if the tests were skipped in case rpmbuild or mock is invoked with --nocheck.

Comment 5 Adrian Reber 2020-10-02 10:29:15 UTC
(In reply to Kalev Lember from comment #2)
> I see that it's fixed in rawhide now with the update to 3.13.0, but the F33
> version is still FTBFS. This is blocking various flatpak builds; would be
> nice to get the F33 build fixed as well.

(In reply to Kalev Lember from comment #3)
> OK, I tracked down the fix in 3.13.0: upstream has just disabled the failing
> test. I'll go and backport this to F33 so that we can get the FTBFS fixed.

Good, because a protobuf update requires rebuilding over 50 packages for the new SO name.

Comment 6 Fedora Update System 2020-10-02 14:46:07 UTC
FEDORA-2020-0f4007d398 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0f4007d398

Comment 7 Kalev Lember 2020-10-02 14:49:26 UTC
https://src.fedoraproject.org/rpms/protobuf/c/7c45611c5a9bbeb628a57695c1a23c7a22972d2b?branch=f33 is the patch that fixed FTBFS. I went ahead and bumped the package to 3.12.4 as well while at this: it brings just a version bump and a tiny fix.

> It would be also good if the tests were skipped in case rpmbuild or mock is invoked with --nocheck.

I'll leave that to the package owner :) I'm just doing some provenpackager intervention here to get things back to working and I'm not the package maintainer for this.

Comment 8 Kamil Dudka 2020-10-02 15:22:04 UTC
OK.  Thank you for fixing the build failure!

Comment 9 Fedora Update System 2020-10-02 22:16:38 UTC
FEDORA-2020-0f4007d398 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-0f4007d398`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-0f4007d398

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-10-05 00:17:10 UTC
FEDORA-2020-0f4007d398 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.