Bug 1881476 - new container images are not pulled if using :16.1
Summary: new container images are not pulled if using :16.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-paunch
Version: 16.1 (Train)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: z4
: 16.1 (Train on RHEL 8.2)
Assignee: Alex Schultz
QA Contact: David Rosenfeld
URL:
Whiteboard:
: 1913039 (view as bug list)
Depends On:
Blocks: 1897306
TreeView+ depends on / blocked
 
Reported: 2020-09-22 13:41 UTC by Alex Schultz
Modified: 2021-03-22 10:55 UTC (History)
6 users (show)

Fixed In Version: python-paunch-5.3.3-1.20200826193408.el8ost
Doc Type: Bug Fix
Doc Text:
Before this update, if a user configured the `ContainerImagePrepare` parameter to use a custom tag, such as 'tag: "latest"' or 'tag: "16.1"', instead of the standard 'tag_from_label: "{version}-{release}"', the containers did not update to the latest container images. With this update, the container images are always fetched anytime a user runs a deployment action, including updates, and the image ID is checked against the running container to see if it needs to be rebuilt to consume the latest image. Containers are now always refreshed during deployment actions and restarted if they are updated. NOTE: This is a change from previous versions where the deployment checked only that the image existed rather than always fetching the image. If a user is reusing tags, for example, "latest", the containers might be updated on nodes if you perform actions such as scaling out. It is not recommended to use "latest" unless you are controlling container tags by using a Satellite server deployment.
Clone Of:
Environment:
Last Closed: 2021-03-17 15:32:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1895974 0 None None None 2020-09-22 13:43:11 UTC
OpenStack gerrit 752937 0 None MERGED Trigger container update on image id update 2021-02-15 16:11:35 UTC
Red Hat Product Errata RHBA-2021:0817 0 None None None 2021-03-17 15:34:06 UTC

Description Alex Schultz 2020-09-22 13:41:48 UTC
This bug was initially created as a copy of Bug #1879531

I am copying this bug because: 

This affects all versions after 13, including 16.1.  If a user is reusing tags, the containers are not fetched and not rebuilt using updated images.


Description of problem:
Customer performed minor update from RHOSP13z11 to 13z12. The update went successfull, but it was observed that some of the container's images were not pulled correctly.

Version-Release number of selected component (if applicable):
RHOSP13z12
Satellite 6.x is used as image registry

How reproducible:
- Container images are prepared with the tag 'latest'.
- Minor update from 13z11 to 13z12 is performed.

Steps to Reproduce:
1.
2.
3.

Actual results:
Latest image is not pulled during update for some of the containers
we Identified 2 container in existing customer setup.
- neutron_ovs_agent
- nova_libvirt

Expected results:
It is expected that all the containers should be updated to the latest images present in satellite content view.

Additional info:

- Same satellite content view is used when scale-out of new compute is done and it is observed that newly scaled out computes having containers with latest packages in them.
- Manually doing the docker pull with tag 'latest' is pulling the latest image for those containers but it seems that it is not happening during minor update.

[root@com003 ~]# docker pull satellite.deployment.be:5000/cloud-oscar05-pxs_osp13-osp13_containers-neutron-openvswitch-agent:latest
Trying to pull repository satellite.deployment.be:5000/cloud-oscar05-pxs_osp13-osp13_containers-neutron-openvswitch-agent ...
latest: Pulling from satellite.deployment.be:5000/cloud-oscar05-pxs_osp13-osp13_containers-neutron-openvswitch-agent
Digest: sha256:71da2d60264996c80eec418371322ef7c2856e030aae054fff967b05afb88fb1
Status: Image is up to date for satellite.deployment.be:5000/cloud-oscar05-pxs_osp13-osp13_containers-neutron-openvswitch-agent:latest

Comment 2 Alex Schultz 2021-01-05 20:42:02 UTC
*** Bug 1913039 has been marked as a duplicate of this bug. ***

Comment 20 errata-xmlrpc 2021-03-17 15:32:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.4 director bug fix advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0817


Note You need to log in before you can comment on or make changes to this bug.