Bug 188156 - fixps broken - tries to re-create directory
fixps broken - tries to re-create directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 10:41 EDT by Mihai Ibanescu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.13b-56
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 09:45:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to use AC_ variants instead of AM_ for newer autoconf (548 bytes, patch)
2006-09-18 07:50 EDT, Patrice Dumas
no flags Details | Diff

  None (edit)
Description Mihai Ibanescu 2006-04-06 10:41:20 EDT
Description of problem:
On my fc5 system, if I try to run a2ps with a postscript file, it will fail with
a "mkdir: cannot create directory blah". I traced it down in fixps which is a
bash script.
This is the problem:
On line 41: tmpdir=$(mktemp -d /tmp/$program.XXXXXX)
On line 194:  mkdir $tmpdir

This will fail because mktemp already created the directory.

Version-Release number of selected component (if applicable):
a2ps-4.13b-49

How reproducible:
/usr/bin/fixps -q /tmp/y.ps
mkdir: cannot create directory `/tmp/fixps.k18151': File exists

Additional info:
Simple solution would be to change line 194 to mkdir -p
Comment 1 John Hodrien 2006-08-08 09:10:48 EDT
Confirmed.  Why not just remove that mkdir call though?  Seems to be superfluous
given the behaviour of mktemp.
Comment 2 Mihai Ibanescu 2006-08-08 09:32:12 EDT
Sure, I guess I was looking for the safest fix. Removing that line should be
just fine.
Comment 3 Patrice Dumas 2006-09-17 15:58:50 EDT
Strangely it is fixed in cvs, but not published in the
devel repo?
Comment 4 Tim Waugh 2006-09-18 06:23:38 EDT
Problems building it.. :-(
Comment 5 Patrice Dumas 2006-09-18 07:48:41 EDT
I think that the attached patch allows to rebuild.

However I think it would be much simpler if the autotools weren't
run. From a look at the patches, I can't see why it should be needed?
Couldn't calling external libtool be sufficient? Or did I miss 
something?
Comment 6 Patrice Dumas 2006-09-18 07:50:21 EDT
Created attachment 136533 [details]
patch to use AC_ variants instead of AM_ for newer autoconf
Comment 7 Tim Waugh 2006-09-27 05:16:29 EDT
Thanks!  Possibly it isn't needed any more, but at this stage we're really
trying to stick to minimal changes..
Comment 8 Patrice Dumas 2006-09-27 06:22:30 EDT
I think it has never been needed, and it is more a little 
packaging mistake (although I cannot say for sure).

I have spotted many issues in the a2ps package, it is not
up-to-date with regard with the packaging guidelines and 
best practices -- like many packages in core. I have allready
(and completly independently) filled a bug for the split of
a -devel package, but I think filling many bugs for packaging
issues is a lost of time. In my opinion to have more feedback and
avoid time lost in following those many little packaging bugs it
would be more practical and less time consuming if you just
started a FC review bug, to help solving all the issues globally.
Of course this is also a time consuming process, but unlike 
a classical review it is allready in core so you'll have all your
time to fix things.

This is for the devel branch only of course, for FC6 it is indeed
better to keep things as they are.

Note You need to log in before you can comment on or make changes to this bug.