Bug 188182 - NetworkManager can't find network devices and warns: "nm_add_initial_devices (): could not find existing networking devices: The maximum number of pending replies per connection has been reached"
NetworkManager can't find network devices and warns: "nm_add_initial_devices ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 14:54 EDT by Myk Melez
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 22:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Myk Melez 2006-04-06 14:54:04 EDT
Description of problem:

When I awoke my FC5 laptop this morning after arriving in the office,
NetworkManager was unable to find any network devices.  I tried unchecking and
then rechecking the "Enable Networking" option in the applet's context menu,
which caused NetworkManager to write the following message to the system log:

Apr  6 11:48:09 myk NetworkManager: <WARNING>    nm_add_initial_devices ():
could not find existing networking devices: The maximum number of pending
replies per connection has been reached

I then tried restarting NetworkManager via "sudo service NetworkManager stop;
sudo service NetworkManager start", and that worked: NetworkManager was once
again able to see my wired and wireless network devices.

Version-Release number of selected component (if applicable): 0.6.0-3

How reproducible: this is the first time it has happened

Additional Info:

[myk@myk ~]$ uptime
 11:57:24 up 9 days,  1:57,  6 users,  load average: 0.10, 0.74, 0.87

I regularly travel between my home and the office, putting my laptop to sleep
for the trip.  I also put the laptop to sleep when going between my desk in the
office (where the laptop has wired access) and other parts of the building for
meetings (where I use the wireless connection).
Comment 1 David Baron 2006-07-21 15:20:47 EDT
I've started seeing this a *lot* (pretty much every time I come into the office,
start in a meeting, as I've been doing every day this week, and then move to my
desk) when switching from wireless to wired.  I suspect something in recent
NetworkManager updates made this worse; restarting NetworkManager made things
work again.

Myk mentioned that he's recently been seeing it a lot more often.
Comment 2 Dan Williams 2007-10-31 22:54:37 EDT
Fixed in FC6 I'm pretty sure; it's running up against an obscenely low D-Bus
pending call limit.  The fix is to either boost the dbus limit or boost the
limit in the NM service config file.

Note You need to log in before you can comment on or make changes to this bug.