Bug 188184 - problem with http proxy in pup and pirut
problem with http proxy in pup and pirut
Status: CLOSED DUPLICATE of bug 185309
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-06 15:04 EDT by das_deniz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 18:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description das_deniz 2006-04-06 15:04:27 EDT
Description of problem:

problem with http proxy in pup and pirut - works fine with yum and yumex

tried export http_proxy http://<server>:<port>
tried adding to /etc/yum.conf as directed in 

  http://fedora.redhat.com/docs/yum/sn-yum-proxy-server.html

using proxy=http://<server>:<port>

and even tried setting the system->preferences-network proxy 

nothing helps pup/pirut

Version-Release number of selected component (if applicable):

  pirut-1.0.1-1

How reproducible:

  always fails - acts like there is no network connection.
Comment 1 Jeremy Katz 2006-04-12 14:17:26 EDT
Can you install http://people.redhat.com/~katzj/yum-2.6.0-2.noarch.rpm and see
if it helps?
Comment 2 das_deniz 2006-04-12 16:25:12 EDT
not a fix, sorry jeremy. 

i did a fresh fc5 install (lost the old machine)
export http_proxy=
yum -y update
rpm -Uvh yum-2.6.0-2.noarch.rpm
and tried pup - same trouble.

so then i added proxy= to the /etc/yum.conf file
tried again... no go
rebooted tried again... still timing out with
"Unable to retrieve software information"
Comment 3 das_deniz 2006-04-13 09:39:57 EDT
oops. i should add that it *absolutely* fixes *yum* for using /etc/yum.conf
proxy= __alone__ (w/o the ENV http_proxy=)

so this *is* a fix for yum proxy handling - 
but fails to resolve the problem for pirut.
Comment 4 Jeremy Katz 2006-04-17 18:24:42 EDT
Aha, I see what's going on.  Marking a dupe of the main bug I'm going to use for
tracking this so that I don't have to juggle a few of these

*** This bug has been marked as a duplicate of 185309 ***
Comment 5 David Lawrence 2006-06-27 21:40:22 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.