Bug 1882026 - Notifications says "No Workloads found" if no resources exists on Topology/ Add View
Summary: Notifications says "No Workloads found" if no resources exists on Topology/ A...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-23 15:50 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:44:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6727 0 None closed Bug 1882026: update notifications message on Topology and removes from Add 2020-10-07 04:47:09 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:45:23 UTC

Description Jaivardhan Kumar 2020-09-23 15:50:16 UTC
Description: Notifications says "No Workloads found" if no resources exists on Topology/ Add View

Prerequisites (if any, like setup, operators/versions):NA

Steps to Reproduce
1. Create a nameSpace
2. Go to Dev Console -> Add
3. Go To Dev Console -> Topology

Actual results:
- on Topology page / Add page Notifications says "No Workloads found" if no resources exists but now we don't just create workloads we do create other resources like EventSources/ Channels etc so shall we use a generic term ?
  

- Shall we show notification only on topology or on add page as well as if user goes to Add directly they want to create a resource and we pull/ fetch resources here (which can be avoided)

Expected results: Show a generic notification instead of "No Workloads found"

Reproducibility (Always/Intermittent/Only Once): Always

Build Details: 4.6.0-0.nightly-2020-09-22-073212

Additional info:

Comment 1 Jaivardhan Kumar 2020-09-23 15:51:55 UTC
Jira for internal tracking https://issues.redhat.com/browse/ODC-4907

Comment 3 Abhinandan Das 2020-09-24 13:33:36 UTC
Verified on

OpenShift Version
4.6.0-0.ci-2020-09-24-005107
Kubernetes Version
v1.19.0-rc.2.1050+fff818330f036c-dirty
Channel
stable-4.6
Cluster ID
28e170ab-82fc-40f5-b887-45161e12e205
API Server
https://api.sp101.devcluster.openshift.com:6443

Comment 6 errata-xmlrpc 2020-10-27 16:44:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.