Bug 1882077 - [release 4.6] operator-lifecycle-manager: Fix bug in reflector not recovering from "Too large resource version"
Summary: [release 4.6] operator-lifecycle-manager: Fix bug in reflector not recovering...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Nick Hale
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On: 1880369
Blocks: 1879901 1880359 1882379
TreeView+ depends on / blocked
 
Reported: 2020-09-23 18:34 UTC by Lukasz Szaszkiewicz
Modified: 2020-10-27 16:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1880359
: 1882379 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:44:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1775 0 None closed Bug 1882077: Bump k8s dependencies to v0.18.9 2020-11-25 09:20:10 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:45:23 UTC

Comment 3 Jian Zhang 2020-09-25 10:16:27 UTC
LGTM, verify it. The regression test pass, and the libs have been update to v0.18.9
Cluster version is 4.6.0-0.nightly-2020-09-25-034954
mac:~ jianzhang$ oc -n openshift-operator-lifecycle-manager exec catalog-operator-568996d5bd-zflr9 -- olm --version
OLM version: 0.16.1
git commit: be18debfbb25ba768921373d48aa761b951eca59

[root@preserve-olm-env operator-lifecycle-manager]# go list -m all |grep client-go
github.com/openshift/client-go v0.0.0-20200326155132-2a6cd50aedd0 => github.com/openshift/client-go v0.0.0-20200326155132-2a6cd50aedd0
k8s.io/client-go v0.18.9
[root@preserve-olm-env operator-lifecycle-manager]#

Comment 6 errata-xmlrpc 2020-10-27 16:44:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.