Bug 188212 - /etc/nsswitch.conf adds nisplus which breaks stuff !
/etc/nsswitch.conf adds nisplus which breaks stuff !
Status: CLOSED DUPLICATE of bug 186592
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-04-06 20:56 EDT by Donald Cohen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-07 05:30:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2006-04-06 20:56:02 EDT
Description of problem:
 I *think* this is related to glibc.
 The problem is a new /etc/nsswitch.conf that adds nisplus
 all over the place, and this breaks lots of stuff (at least for me).
Version-Release number of selected component (if applicable):
 glibc-devel.i386 2.3.6-3

How reproducible:
 first, see where nsswitch comes from.  Then see whether the new
 version contains nisplus.

Steps to Reproduce:
Actual results:
For me the result of nsswitch.conf containing
  hosts:      files nisplus dns
is that I can no longer use wget, which means that yum no longer
works.  For that matter other things break too, like ssh -p 2222 ...
 # wget http://ap5.com/
 --14:21:20--  http://ap5.com/
           => `index.html.1'
 Resolving ap5.com... failed: No such file or directory.

Expected results:
 above wget should work
 removing nisplus from the line above fixes the problem

Additional info:
I don't understand why adding nisplus should cause a lookup
to fail.  Perhaps that's another bug.  Don't you think it's
a bit dangerous to go around changing peoples config files?
This is not the first time an automatic update has broken
something for me.  Is there some solution?
Unfortunately, for others like me,it will not be sufficient
to just distribute an update!  I need yum to get the update
and you've broken it.
Comment 1 Jakub Jelinek 2006-04-07 05:30:19 EDT

*** This bug has been marked as a duplicate of 186592 ***

Note You need to log in before you can comment on or make changes to this bug.