Bug 188218 - Update request: banshee 0.10.10
Update request: banshee 0.10.10
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
http://banshee-project.org/Releases/0...
:
Depends On: 196500
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-04-07 00:34 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 11:41:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-04-07 00:34:31 EDT
Description of problem:
Banshee 0.10.9 is out

Version-Release number of selected component (if applicable):
banshee-0.10.8-1

Additional info:
Banshee summary should probably start with the first letter capitalized, i.e.
"Easily"

0.10.9 installs fine on my machine, but the Music Library icon changes to the
GNOME "Home" icon, which seems like a regression.
Comment 1 petrosyan 2006-05-24 20:56:21 EDT
Banshee 0.10.10 was released on May 1, 2006
Comment 2 Michel Alexandre Salim 2006-07-11 23:10:40 EDT
Seems to require as-yet unpackaged njb-sharp, bug #196500
Comment 3 Alex Lancaster 2006-09-09 08:12:53 EDT
Banshee is now up to 0.10.12 (released on August 23, 2006):

http://banshee-project.org/Releases/0.10.12

Can the reporter bump up the summary to mention update to 0.10.12?

A package review (bug #204700) has been opened for njb-sharp support. 
Meanwhile, can Banshee be configured without the njb support and updated to the
latest version?
Comment 4 Alex Lancaster 2006-09-09 08:18:46 EDT
NJB and iPod support is now optional, according to:

http://banshee-project.org/Banshee_Source

 "If you have an NJB Digital Media Player or an iPod, you may want to build      
  Banshee with support for your device. However, this is now optional."

You can build this without njb support using this configure option

--disable-njb: Disable the NJB features because you don't have an NJB device or
expect to have one to use on this version.

The only hard dependencies are:

    * Mono 1.1.10 or better
    * Gtk# 2.8
    * HAL 0.5.2 or better
          o Linux 2.6 kernel 
    * D-Bus 0.36.2 (and dbus-sharp) or better
    * GStreamer 0.10.3+
    * libmusicbrainz 2.1.1 or better
    * libnautilus-burn 2.12 or better
    * GTK+ 2.2
    * sqlite3 libraries 

I would suggest a rebuild with the latest version without njb support until such
time as the njb-sharp package is reviewed and released.
Comment 5 Alex Lancaster 2006-09-09 08:27:17 EDT
Lastly, it must be possible to build 0.10.12 without njb-sharp, because I see
that it's been done in the devel branch and there's still no njb-sharp package
in Extras:

http://fedoraproject.org/extras/development/i386/repodata/repoview/banshee-0-0.10.12-4.fc6.html
Comment 6 Alex Lancaster 2006-09-23 20:18:14 EDT
Ping?  Banshee is now at 0.11!

http://banshee-project.org/Releases/0.11.0

No response on this bug for 7 months!  Has this package been orphaned?

Comment 7 Alex Lancaster 2006-09-23 20:45:38 EDT
According to this:

http://cvs.fedora.redhat.com/viewcvs/rpms/banshee/FC-5/banshee.spec?root=extras&r1=1.8&r2=1.9

CVS commit, the package spec was updated to 0.10.10, but no package was ever pushed!

Comment 8 Christopher Aillon 2006-09-25 11:41:16 EDT
Banshee 0.10.10 didn't build in FC5.  This package is not orphaned, but it is
simply a new version of a package.  FC5 is now considered stable, and the point
of continuing to use it is that some packages get stabliized and not updated
that often.  If you want updates every time a new version is out, you should be
using Rawhide.

Since there is no specific bug that users are having other than "not latest",
this is WONTFIX.  Not going to update just to say its the latest version.
Comment 9 Alex Lancaster 2006-09-25 14:58:06 EDT
(In reply to comment #8)
> Banshee 0.10.10 didn't build in FC5.  

OK, but have you tried the more recent version such as 0.10.12 or 0.11?  AFAIK 0.10.10 didn't 
build because the libnjb (for Nomad players) was hard dependency and I believe that hard 
dependency was removed since.

It wouldn't hurt to try to see if the latest will build and it will keep users happy to have the latest 
version of things (not to mention less upstream reports from people reporting bugs that have been 
fixed in the more recent version).
Comment 10 Christopher Aillon 2006-09-25 15:26:39 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > Banshee 0.10.10 didn't build in FC5.  
> 
> OK, but have you tried the more recent version such as 0.10.12 or 0.11?  AFAIK
0.10.10 didn't 
> build because the libnjb (for Nomad players) was hard dependency and I believe
that hard 
> dependency was removed since.

There never was a hard requirement on njb.  0.10.10 was built in development
without njb.  I've had banshee built since before 0.10.10 even without the
dependency.  The issue was API changes to dbus and a few other things.  

 
> It wouldn't hurt to try to see if the latest will build and it will keep users
happy to have the latest 
> version of things (not to mention less upstream reports from people reporting
bugs that have been 
> fixed in the more recent version).

Again, users still use FC5 because it is stable.  If they want the absolute
latest versions of things, they will be using rawhide.
Comment 11 Alex Lancaster 2006-09-25 15:37:13 EDT
(In reply to comment #10)

> Again, users still use FC5 because it is stable.  If they want the absolute
> latest versions of things, they will be using rawhide.

Well, it seems a little too much to use rawhide for one package.  In any case,
many other Extras maintainers make a point of keeping up with the latest
packages where possible.

If banshee > 0.10.9 requires more recent core packages such as dbus, that's a
different matter, then it requires more core dependencies to be updated, then I
can understand not upgrading.  

I think for many packages in Extras (for example maxima or R), are generally
kept in sync with the stable version of upstream so long as they don't require
more recent Core updates.  In fact there are updates often in days after the
release of those upstream package upgrades.

Note You need to log in before you can comment on or make changes to this bug.