Bug 1882293 - In the N-1 capsule sync, "Packet too short or invalid while reading the response record. (Maybe a UTF-8 problem?)" messages get continuously
Summary: In the N-1 capsule sync, "Packet too short or invalid while reading the respo...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule
Version: 6.8.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Vladimír Sedmík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-24 09:24 UTC by Devendra Singh
Modified: 2020-09-25 08:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-24 12:43:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Devendra Singh 2020-09-24 09:24:53 UTC
Description of problem: In the N-1 capsule sync, "Packet too short or invalid while reading the response record. (Maybe a UTF-8 problem?)" messages get continuously


Version-Release number of selected component (if applicable):
6.8 Snap17 

How reproducible:
always

Steps to Reproduce:
1. Install staellite & Capsule with the latest 6.7 GA version
2. Upgrade satellite frm 6.7 to 6.8.
3. Keep capsule on the 6.7 version.
4. Perform Optimized capsule sync.

Actual results:
During sync a lot of message were seen like "avahi-daemon[801]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)"

Expected results:
These messages should not come.

Additional info:

Comment 2 Adam Ruzicka 2020-09-24 09:46:46 UTC
As far as I know no part of satellite is actively using avahi, I don't even have it installed at all on any of my satellites. Either it is a misconfiguration on your machine or a bug in avahi, but it is definitely not something we should try to address in satellite.

Comment 3 Devendra Singh 2020-09-24 10:47:44 UTC
(In reply to Adam Ruzicka from comment #2)
> As far as I know no part of satellite is actively using avahi, I don't even
> have it installed at all on any of my satellites. Either it is a
> misconfiguration on your machine or a bug in avahi, but it is definitely not
> something we should try to address in satellite.

yes, you are right, this is not related to satellite, Can we close it as not a bug?

Comment 4 Lukas Zapletal 2020-09-24 12:41:30 UTC
Yes this can be closed, feel free to report on the avahi component if you like.


Note You need to log in before you can comment on or make changes to this bug.