Bug 1882358 - Installing KDE from the Netinst image produces a different result than from a Live image
Summary: Installing KDE from the Netinst image produces a different result than from a...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pungi
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lubomír Sedlář
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-24 11:13 UTC by Lukas Ruzicka
Modified: 2021-02-12 15:08 UTC (History)
19 users (show)

Fixed In Version: pungi-4.2.7-2.fc33 pungi-4.2.7-2.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-12 15:08:48 UTC
Type: Bug


Attachments (Terms of Use)
The Internet menu (797.72 KB, image/png)
2020-09-24 11:13 UTC, Lukas Ruzicka
no flags Details
KDE Live 1.3 rpms (57.19 KB, text/plain)
2020-09-24 12:37 UTC, Kamil Páral
no flags Details
KDE netinst 1.3 rpms (54.42 KB, text/plain)
2020-09-24 12:37 UTC, Kamil Páral
no flags Details
The Workstation packages that are not installed by Netinst (3.27 KB, text/plain)
2021-01-29 14:15 UTC, Lukas Ruzicka
no flags Details

Description Lukas Ruzicka 2020-09-24 11:13:53 UTC
Created attachment 1716311 [details]
The Internet menu

Description of problem:

When I installed KDE using the Everything ISO (Beta RC 1.3), the system has no web browser installed.

Version-Release number of selected component (if applicable):

Beta RC 1.3

How reproducible:

Always

Steps to Reproduce:
1. Use Everything ISO
2. Select KDE Workspaces

Actual results:

No web browser installed.

Expected results:

A web browser must be installed as it is one of the core applications.

Additional info:

See the attached picture.

Comment 1 Fedora Blocker Bugs Application 2020-09-24 11:16:51 UTC
Proposed as a Blocker for 33-beta by Fedora user lruzicka using the blocker tracking app because:

 Required applications

It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments.

Comment 2 Kamil Páral 2020-09-24 12:36:34 UTC
I can confirm this. KDE Live has 1694 rpms, while KDE installed from netinst has 1604 rpms. Firefox and Falkon are missing from the netinst system, but the difference is much bigger. Some packages are included because of anaconda deps on Live, but there are many more which are unrelated, like Calligra also missing from netinst system.

Comment 3 Kamil Páral 2020-09-24 12:37:03 UTC
Created attachment 1716332 [details]
KDE Live 1.3 rpms

Comment 4 Kamil Páral 2020-09-24 12:37:22 UTC
Created attachment 1716333 [details]
KDE netinst 1.3 rpms

Comment 5 Kamil Páral 2020-09-24 12:43:01 UTC
This seems to be a problem somewhere in comps or kickstarts? Reassigning.

Comment 6 Kevin Fenzi 2020-09-24 14:00:43 UTC
Those packages are options in the netinstall:

    <optionlist>
      <groupid>firefox</groupid>
      <groupid>cinnamon-desktop</groupid>
      <groupid>gnome-desktop</groupid>
      <groupid>input-methods</groupid>
      <groupid>kde-desktop</groupid>
      <groupid>legacy-fonts</groupid>
      <groupid>libreoffice</groupid>
      <groupid>lxde-desktop</groupid>
      <groupid>lxqt-desktop</groupid>
      <groupid>mate-desktop</groupid>
      <groupid>sugar-desktop</groupid>
      <groupid>xfce-desktop</groupid>
      <groupid>xmonad</groupid>
      <groupid>xmonad-mate</groupid>
    </optionlist>


and pulled into the live media in kickstart: 

@firefox
@kde-apps
@kde-desktop
@kde-media
@kde-office
@networkmanager-submodules

So, I think it's intended. You have to select those option groups on netinstall to get them.

Comment 7 Rex Dieter 2020-09-24 14:08:31 UTC
Is this a regression from prior releases?

If not, I'd expect that selecting "KDE Workspaces" to install exactly that: the KDE Plasma desktop environment.  Nothing more, nothing less.  

Here's what comps includes:

  <environment>
    <id>kde-desktop-environment</id>
    <_name>KDE Plasma Workspaces</_name>
    <_description>The KDE Plasma Workspaces, a highly-configurable graphical user interface which includes a panel, desktop, system icons and desktop widgets, and many powerful KDE applications.</_description>
    <display_order>10</display_order>
    <grouplist>
      <groupid>base-x</groupid>
      <groupid>standard</groupid>
      <groupid>core</groupid>
      <groupid>admin-tools</groupid>
      <groupid>dial-up</groupid>
      <groupid>fonts</groupid>
      <groupid>input-methods</groupid>
      <groupid>multimedia</groupid>
      <groupid>networkmanager-submodules</groupid>
      <groupid>hardware-support</groupid>
      <groupid>printing</groupid>
      <groupid>guest-desktop-agents</groupid>
      <groupid>kde-desktop</groupid>
    </grouplist>
    <optionlist>
      <groupid>firefox</groupid>
      <groupid>kde-apps</groupid>
      <groupid>kde-education</groupid>
      <groupid>kde-media</groupid>
      <groupid>kde-office</groupid>
      <groupid>kde-telepathy</groupid>
      <groupid>3d-printing</groupid>
      <groupid>cloud-management</groupid>
    </optionlist>
  </environment>

I am unsure if anaconda supports the "optionlist" stuff anymore, but that's where all (most?) of the missing items referenced here come from.  I believe they all default to off, so you'll have to opt-in to get those extra items.

Comment 8 Ben Cotton 2020-09-24 14:12:05 UTC
I understand the reasoning behind nominating it as a blocker, but I think it's an over-broad interpretation of the criteria in this case. I'm inclined to call this NOTABUG unless the KDE SIG decides they want to change the intended behavior.

Comment 9 Kamil Páral 2020-09-24 15:36:47 UTC
I installed KDE from F32 netinst and I can confirm the same situation is there, there's no web browser preinstalled by default.

If this is expected, well, OK. But I was always operating on the assumption that the Live and the netinst produce the same desktop environment, with the same set of packages (disregarding anaconda+deps) and same configuration. If this is not the case, I feel we'll need to re-think our approach to release blocking environments, because testing environment X from Live and from netinst separately and with different expectations would have large multiplication effects on our QA testcases and also would require changes to the release criteria. So if we say "this is fine for F33, it was the same in F32", I feel we'll need to have a follow-up discussion about it.

I'd prefer if both Live and netinst installed the same set. In anaconda, those optional groups (which get pulled in automatically on Lives) could be selected by default, but the users could unselect them if they wanted.

Comment 10 Geoffrey Marr 2020-09-24 19:19:06 UTC
Discussed during the 2020-09-24 Fedora 33 Go/No-Go meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Beta)" was made as this is intended behavior. It may be worth later discussion about how we apply the criterion in question.

[0] https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2020-09-24/f33-beta-go_no_go-meeting.2020-09-24-17.00.txt

Comment 11 Rex Dieter 2020-09-25 14:14:45 UTC
ah, I now see the subtle point highlighted in comment #9, that live and netinst should produce similar results. I very much agree with that goal.

I think we can move toward that goal by adjusting the kde-desktop-environment optionlist to include the same defaults that live images do.  I'll work on that.

Comment 12 Kamil Páral 2020-09-25 14:37:31 UTC
Thanks, Rex!

Comment 13 Rex Dieter 2020-09-25 18:22:06 UTC
This PR should be a good step in the right direction:
https://pagure.io/fedora-comps/pull-request/534

Comment 14 Kevin Fenzi 2020-11-01 06:00:33 UTC
The pr was merged, but kparal said "I downloaded Fedora-Everything-netinst-x86_64-33-20201007.n.0.iso and when I select KDE Plasma Workspaces in Software selection, I still see all Addons unselected. Am I doing something wrong?" in the pr comments. 

Is that still the case with f33 final or rawhide images?

Comment 15 Kamil Páral 2020-11-02 08:56:23 UTC
(In reply to Kevin Fenzi from comment #14)
> Is that still the case with f33 final or rawhide images?

Yes, with Fedora-Everything-netinst-x86_64-33-1.2.iso I still see the same problem, all Addons are unselected after selecting KDE Plasma.

Comment 16 Kevin Fenzi 2020-11-03 18:16:20 UTC
Not sure whats going on here. They seem to be marked in compos correctly. Anything in anaconda logs related?

Comment 17 Kamil Páral 2020-11-04 14:11:52 UTC
Kevin, when I look at today's comps-Everything.x86_64.xml in the master mirror [1], I see this:

<id>kde-desktop-environment</id>
<name>KDE Plasma Workspaces</name>
...
<optionlist>
<groupid>3d-printing</groupid>
<groupid>cloud-management</groupid>
<groupid>firefox</groupid>
<groupid>kde-apps</groupid>
<groupid>kde-education</groupid>
<groupid>kde-media</groupid>
<groupid>kde-office</groupid>
<groupid>kde-telepathy</groupid>
</optionlist>

So the PR doesn't seem be in effect, default="true" is not added to the selected groups. Is this an infra bug?


[1] https://dl.fedoraproject.org/pub/fedora/linux/updates/33/Everything/x86_64/repodata/

Comment 18 Kevin Fenzi 2020-11-07 19:36:40 UTC
So, it's in fedora-comps git. It's in the rawhide.xml that gets made from there, but it's not in the pungi working versions. 

So, this might be a pungi bug?

2020-11-03 05:17:00 [DEBUG   ] Exporting file comps-rawhide.xml from git https://pagure.io/fedora-comps.git (branch a1483bb603fb9ba5479cb97931975cfc34d43e42)...
2020-11-03 05:17:01 [DEBUG   ] Running "make comps-rawhide.xml"

^ it seems fine here. 

2020-11-03 05:17:03 [DEBUG   ] Writing comps file for arch 'aarch64': /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/aarch64/comps/comps-aarch64.xml
2020-11-03 05:17:03 [DEBUG   ] Writing comps file for arch 'armhfp': /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/armhfp/comps/comps-armhfp.xml
2020-11-03 05:17:03 [DEBUG   ] Writing comps file for arch 'ppc64le': /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/ppc64le/comps/comps-ppc64le.xml
2020-11-03 05:17:03 [DEBUG   ] Writing comps file for arch 's390x': /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/s390x/comps/comps-s390x.xml
2020-11-03 05:17:03 [DEBUG   ] Writing comps file for arch 'x86_64': /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/x86_64/comps/comps-x86_64.xml
2020-11-03 05:17:03 [INFO    ] [BEGIN] Creating comps repo for arch 'x86_64' variant 'None'
2020-11-03 05:17:03 [INFO    ] [BEGIN] Creating comps repo for arch 'aarch64' variant 'None'
2020-11-03 05:17:03 [INFO    ] [BEGIN] Creating comps repo for arch 'armhfp' variant 'None'
2020-11-03 05:17:03 [INFO    ] [DONE ] Creating comps repo for arch 'x86_64' variant 'None'
2020-11-03 05:17:03 [INFO    ] [BEGIN] Creating comps repo for arch 's390x' variant 'None'
2020-11-03 05:17:03 [INFO    ] [DONE ] Creating comps repo for arch 'aarch64' variant 'None'
2020-11-03 05:17:03 [INFO    ] [BEGIN] Creating comps repo for arch 'ppc64le' variant 'None'
2020-11-03 05:17:03 [INFO    ] [DONE ] Creating comps repo for arch 'armhfp' variant 'None'
2020-11-03 05:17:03 [INFO    ] [DONE ] Creating comps repo for arch 's390x' variant 'None'
2020-11-03 05:17:03 [INFO    ] [DONE ] Creating comps repo for arch 'ppc64le' variant 'None'
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: aarch64, variant: Cloud): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/aarch64/comps/comps-Cloud.aarch64.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: s390x, variant: Cloud): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/s390x/comps/comps-Cloud.s390x.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: ppc64le, variant: Cloud): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/ppc64le/comps/comps-Cloud.ppc64le.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: x86_64, variant: Cloud): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/x86_64/comps/comps-Cloud.x86_64.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: aarch64, variant: Container): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/aarch64/comps/comps-Container.aarch64.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: armhfp, variant: Container): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/armhfp/comps/comps-Container.armhfp.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: ppc64le, variant: Container): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/ppc64le/comps/comps-Container.ppc64le.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: ppc64le, variant: Everything): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/ppc64le/comps/comps-Everything.ppc64le.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: s390x, variant: Container): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/s390x/comps/comps-Container.s390x.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: armhfp, variant: Everything): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/armhfp/comps/comps-Everything.armhfp.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: s390x, variant: Everything): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/s390x/comps/comps-Everything.s390x.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: aarch64, variant: Everything): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/aarch64/comps/comps-Everything.aarch64.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: x86_64, variant: Container): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/x86_64/comps/comps-Container.x86_64.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: armhfp, variant: Labs): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/armhfp/comps/comps-Labs.armhfp.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: x86_64, variant: Labs): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/x86_64/comps/comps-Labs.x86_64.xml
2020-11-03 05:17:04 [DEBUG   ] Writing comps file (arch: x86_64, variant: Everything): /mnt/koji/compose/rawhide/Fedora-Rawhide-20201103.n.0/work/x86_64/comps/comps-Everything.x86_64.xml

Its not in these ^ 

Moving to pungi for comment. :)

Comment 19 Kamil Páral 2021-01-15 14:20:33 UTC
This is still broken, in both F33 and Rawhide. 'default="true"' is missing in the optionlist. We need somebody from pungi to respond there, thanks.

Comment 20 Lubomír Sedlář 2021-01-21 15:45:33 UTC
This is indeed a bug. The post processing that happens on comps did not emit the attribute in the result.
This should fix it: https://pagure.io/pungi/pull-request/1484

Comment 21 Fedora Update System 2021-01-22 10:37:02 UTC
FEDORA-2021-0ecd4abda7 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-0ecd4abda7

Comment 22 Fedora Update System 2021-01-23 01:20:46 UTC
FEDORA-2021-b9351b8915 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b9351b8915`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b9351b8915

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2021-01-23 02:09:52 UTC
FEDORA-2021-0ecd4abda7 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-0ecd4abda7`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-0ecd4abda7

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 24 Lukas Ruzicka 2021-01-29 14:13:51 UTC
I have tested this on yesterday's rawhide compose and I can confirm that now, Workstation installed from Live and from Netinst are the same from the user's perspective.

The differ in some of the packages - Netinst installs 1612 packages and Live installs 1707 packages. It seems to me, that none of those extra packages is actually important for the system. 

I have listed the extra packages and added them attached if you want to see it, but I think this bug is VERIFIED.

Comment 25 Lukas Ruzicka 2021-01-29 14:15:09 UTC
Created attachment 1752060 [details]
The Workstation packages that are not installed by Netinst

Comment 26 Kamil Páral 2021-01-29 15:18:58 UTC
Well, Rawhide's comps really contains default="true" at the right places. However, those attributes are still missing in comps in today's F33 updates repo. Lubomír, Kevin, why is that?

Comment 27 Kevin Fenzi 2021-01-30 20:35:26 UTC
Because just pushing a pungi update doesn't update bodhi-backend01 where these updates are made. :) 

I'm updating it now, please check after todays 00:14 compose?

Comment 28 Kamil Páral 2021-02-01 13:59:58 UTC
No, as of 2021-02-01 compose, the F33 updates repo still doesn't contain the updated tags.

Comment 29 Fedora Update System 2021-02-07 01:32:13 UTC
FEDORA-2021-0ecd4abda7 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 30 Fedora Update System 2021-02-07 01:38:35 UTC
FEDORA-2021-b9351b8915 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 31 Kevin Fenzi 2021-02-07 22:55:14 UTC
Yeah, still not there. ;( 

Any ideas Lubomir?

Comment 32 Lubomír Sedlář 2021-02-08 07:16:43 UTC
The fix is backported in 4.2.7-2.fc32, but bodhi-backend01.iad2.fedoraproject.org is using pungi-4.2.7-1.fc32:
https://kojipkgs.fedoraproject.org/compose/updates/Fedora-33-updates-20210208.0/logs/global/pungi.global.log
Was the update successful?

Comment 33 Kevin Fenzi 2021-02-08 20:27:24 UTC
Bah. I thought it was in 4.2.7-1. :( 

ok, upgraded. Lets see how it is tomorrow?

Comment 34 Kamil Páral 2021-02-09 08:25:38 UTC
The F33 updates repo is finally correctly updated :-) However, netinst still shows the categories unchecked by default, I'll test out later when the mirrors are synced.

Comment 35 Kamil Páral 2021-02-12 15:08:48 UTC
The F33 netinst still doesn't auto-enable the required addon groups, I filed an anaconda bug 1928181 about it, so that we can close this one.


Note You need to log in before you can comment on or make changes to this bug.