Bug 188240 - Postscript files fail to print on Brother HL-1240
Postscript files fail to print on Brother HL-1240
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 08:25 EDT by Erlend Dahl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.2.rc1.2.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 13:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Postcript file from LaTeX (11.81 KB, application/postscript)
2006-04-07 08:25 EDT, Erlend Dahl
no flags Details
Firefox PS output (79.48 KB, application/postscript)
2006-04-07 08:26 EDT, Erlend Dahl
no flags Details
Foomatic log for Firefox output (5.13 KB, application/octet-stream)
2006-04-07 08:27 EDT, Erlend Dahl
no flags Details
Foomatic log for LaTeX output (5.11 KB, application/octet-stream)
2006-04-07 08:28 EDT, Erlend Dahl
no flags Details
Foomatic log for dvips and lpr -ofitplot=false (5.13 KB, text/plain)
2006-04-07 11:06 EDT, Erlend Dahl
no flags Details

  None (edit)
Description Erlend Dahl 2006-04-07 08:25:30 EDT
Description of problem:

Postcript files fail to print on Brother HL-1240, ghostscript fails

Version-Release number of selected component (if applicable):

Linux cembalo 2.6.16-1.2080_FC5 #1 Tue Mar 28 03:38:34 EST 2006 i686 i686 i386
GNU/Linux
ghostscript-8.15.1-7.1
cups-1.2-0.2.rc1.2.6

How reproducible: Always


Steps to Reproduce:
1. lpr <postcript file>
2.
3.
  
Actual results: File does not print, remains in printer queue


Expected results: File is printed


Additional info:

Foomatic log file shows that ghostscript stops. 

I have tried the hint suggested in 187907 (change the 'fitplot' option to
'false' using system-config-printer), but to no avail.

I attach two ps files that will not print, one from Firefox, the other from
LaTeX (dvips) as well as the corresponding foomatic log files.
Comment 1 Erlend Dahl 2006-04-07 08:25:30 EDT
Created attachment 127454 [details]
Postcript file from LaTeX
Comment 2 Erlend Dahl 2006-04-07 08:26:27 EDT
Created attachment 127455 [details]
Firefox PS output
Comment 3 Erlend Dahl 2006-04-07 08:27:22 EDT
Created attachment 127456 [details]
Foomatic log for Firefox output
Comment 4 Erlend Dahl 2006-04-07 08:28:02 EDT
Created attachment 127457 [details]
Foomatic log for LaTeX output
Comment 5 Tim Waugh 2006-04-07 09:55:40 EDT
Does 'lpr -ofitplot=false ...' work?
Comment 6 Erlend Dahl 2006-04-07 10:09:49 EDT
It works indeed for printing the file generated by Firefox, but not for the
LaTeX / dvips output.
Comment 7 Tim Waugh 2006-04-07 10:57:42 EDT
Can you show me the foomatic-rip.log file for printing the dvips output using
'-ofitplot=false' please?  Thanks.
Comment 8 Erlend Dahl 2006-04-07 11:06:00 EDT
Created attachment 127468 [details]
Foomatic log for dvips and lpr -ofitplot=false
Comment 9 Tim Waugh 2006-04-07 12:42:40 EDT
Please try these rc1.2.8 packages:

  ftp://people.redhat.com/twaugh/tmp/cups-1.2/FC-5

Seems to work here, anyway.
Comment 10 Erlend Dahl 2006-04-07 13:22:19 EDT
Thanks, that worked. Even without -ofitplot=false (but then the printout was
slightly reduced).

Any idea what caused this behaviour?
Comment 11 Tim Waugh 2006-04-07 13:28:10 EDT
Yes; the pstops filter was buggy.  Thanks for testing it.

Note You need to log in before you can comment on or make changes to this bug.