Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1882448 - [release 4.5] openshift-state-metrics: Fix bug in reflector not recovering from "Too large resource version"
Summary: [release 4.5] openshift-state-metrics: Fix bug in reflector not recovering fr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.z
Assignee: Simon Pasquier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1881963
Blocks: 1879901
TreeView+ depends on / blocked
 
Reported: 2020-09-24 15:14 UTC by Simon Pasquier
Modified: 2020-12-15 16:56 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1881963
Environment:
Last Closed: 2020-11-10 14:53:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift openshift-state-metrics pull 58 0 None closed Bug 1882448: bump k8s.io/client-go dependency 2021-01-21 05:23:58 UTC
Red Hat Product Errata RHBA-2020:4425 0 None None None 2020-11-10 14:54:10 UTC

Description Simon Pasquier 2020-09-24 15:14:14 UTC
+++ This bug was initially created as a clone of Bug #1881963 +++

Description of problem:
# oc -n openshift-monitoring logs $(oc -n openshift-monitoring get po | grep openshift-state-metrics | awk '{print $1}') -c openshift-state-metrics | grep "Too large resource version" | tail -n 3
E0922 04:58:46.887235       1 reflector.go:178] github.com/openshift/openshift-state-metrics/pkg/collectors/builder.go:228: Failed to list *v1.Build: Timeout: Too large resource version: 47360, current: 43789
E0922 05:19:35.734025       1 reflector.go:178] github.com/openshift/openshift-state-metrics/pkg/collectors/builder.go:228: Failed to list *v1.DeploymentConfig: Timeout: Too large resource version: 128797, current: 113605
E0922 05:20:19.653911       1 reflector.go:178] github.com/openshift/openshift-state-metrics/pkg/collectors/builder.go:228: Failed to list *v1.DeploymentConfig: Timeout: Too large resource version: 128797, current: 113605

full logs see the attached file
Version-Release number of selected component (if applicable):
4.6.0-0.nightly-2020-09-21-230455
# /usr/bin/openshift-state-metrics --version
version.Version{GitCommit:"1ba41a4", BuildDate:"2020-09-19T21:43:31Z", Release:"v4.6.0-202009192030.p0", GoVersion:"go1.14.7", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
not often, the last time to see this error was E0922 05:20:19.653911, no such error now

Steps to Reproduce:
1. oc -n openshift-monitoring logs $(oc -n openshift-monitoring get po | grep openshift-state-metrics | awk '{print $1}') -c openshift-state-metrics
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Lili Cosic on 2020-09-23 13:52:46 UTC ---

Wonder if its related to the client-go bug? https://bugzilla.redhat.com/show_bug.cgi?id=1881079

--- Additional comment from Simon Pasquier on 2020-09-23 14:39:29 UTC ---

(In reply to Lili Cosic from comment #1)
> Wonder if its related to the client-go bug?
> https://bugzilla.redhat.com/show_bug.cgi?id=1881079

I'd say so.

Comment 5 Junqi Zhao 2020-11-02 02:11:55 UTC
fix is in 4.5.0-0.nightly-2020-10-31-200727, and the client-go version is v0.18.10

Comment 8 errata-xmlrpc 2020-11-10 14:53:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.18 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4425


Note You need to log in before you can comment on or make changes to this bug.