Bug 188248 - webalizer's MangleAgent does not work properly and is missing support for latest common browsers
webalizer's MangleAgent does not work properly and is missing support for lat...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: webalizer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 09:29 EDT by Jarkko
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version: 2.01_10-30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-16 10:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user agent patches for Webalizer 2.01-10 (1.54 KB, patch)
2006-04-07 09:29 EDT, Jarkko
no flags Details | Diff
user agent patches for Webalizer 2.01-10 (1.54 KB, application/x-compressed-tar)
2006-04-07 09:32 EDT, Jarkko
no flags Details

  None (edit)
Description Jarkko 2006-04-07 09:29:15 EDT
Description of problem:

1) Opera browsers are shown like "Opera <version>" or "Opera/<version>"
depending on how Opera was set its user agent. It should be: "Opera/<version>".

2) All mozilla.org browsers are all shown as Mozilla/5.0. I believe Gecko
version deserves to be shown. It should say: "Mozilla/5.0 Gecko <version>".
Also, do not show other Mozilla/5.0 claiming browsers as mangled because they
are liers.

3) Mozilla cloakers are all shown as Mozilla/<version>. There is atleast one big
group of browsers which should be shown separately: AppleWebKit based browsers
(compare, if we show Gecko based browsers as "Mozilla/<mozversion> Gecko
<version>" I believe AppleWebKit based browsers should also be mangled).

4) Mozilla compatible section does not get the browser version necessarily from
the correct location. It should move the pointer right after the ";". Also,
don't accept Mozilla as compatible. Those are liers.

5) Mangling should also group other browsers which notify themselves as the RFC
states (browser/version). I mean the MangleAgent value should have an effect for
how the other agents are shown (i mean their version numbers).


Version-Release number of selected component (if applicable): All versions up
to: webalizer-2.01_10-29.2.1


How reproducible: Always


Steps to Reproduce:
1. Install webalizer.
2. Set MangleAgent to e.g. 4 and run webalizer.
3. Look at agents.

  
Actual results:

Modern browsers aren't detected. Opera is shown with "Opera <version>" and
"Opera/<version>". Other browsers aren't mangled at all.


Expected results:

Support for detecting modern browser frameworks like mozilla.org (Gecko) and
Apple (AppleWebKit). (I believe it is better to support browser frameworks than
actual products because it doesn't matter to the web programmer if the visitor
uses Firefox or Mozilla Suite or similar - but it does matter if the visitor
uses something else like Opera etc. Also, it is easier to try to keep up with
the frameworks than with products. GroupAgent is for product detection in my mind.)


Additional info:


I've fixed all these issues. Patches attached. Just add them to the spec and
you're done.
Comment 1 Jarkko 2006-04-07 09:29:15 EDT
Created attachment 127459 [details]
user agent patches for Webalizer 2.01-10
Comment 2 Jarkko 2006-04-07 09:32:54 EDT
Created attachment 127460 [details]
user agent patches for Webalizer 2.01-10

This is a gzipped tar containing five patches. I marked it as "patch", and
bugzilla didn't like that. :)

So here we go again without the "patch" flag... ;)
Comment 3 Joe Orton 2006-06-16 10:04:01 EDT
Thanks a lot for the patches, Jarkko (and sorry for the delay!) - I've committed
all of these; should hit Raw Hide once the test1 freeze is over.

Note You need to log in before you can comment on or make changes to this bug.