Bug 1882524 - greenwave / CVP is failing on bundle validations, cannot stage push
Summary: greenwave / CVP is failing on bundle validations, cannot stage push
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Luke Meyer
QA Contact: Giriyamma
URL:
Whiteboard:
: 1883951 (view as bug list)
Depends On: 1886200
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-24 19:58 UTC by Luke Meyer
Modified: 2020-10-27 16:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:45:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 664 0 None closed Bug 1882524: fixing bundle image and updating makefile accordingly 2020-12-03 04:02:25 UTC
Github openshift cluster-logging-operator pull 712 0 None closed Bug 1882524: Fixed 4.6 manifests folder and bundle validation 2020-12-03 04:01:58 UTC
Github openshift cluster-logging-operator pull 717 0 None closed Bug 1882524: Remove Kind:LogForwarding 2020-12-03 04:02:00 UTC
Github openshift vertical-pod-autoscaler-operator pull 38 0 None closed bug 1882524: [release-4.6] manifests/art.yaml: CSV name is verticalpodautoscaler 2020-12-03 04:02:00 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:45:45 UTC

Description Luke Meyer 2020-09-24 19:58:37 UTC
Description of problem:
After bundle containers are built, they go through a round of validation. This is failing for some, and stage pushes are not allowed until they pass. Also of course we can't ship them.

This bug is to support upstream PRs where needed to fix this. It can be considered done when all bundles are rebuilt and pass the tests.

Comment 4 Jeff Cantrill 2020-09-30 15:18:02 UTC
*** Bug 1883951 has been marked as a duplicate of this bug. ***

Comment 8 Giriyamma 2020-10-05 06:20:11 UTC
I am verifying this fix on Cluster version 4.6.0-0.nightly-2020-10-03-051134, still seeing old logging csv

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-10-03-051134   True        False         63m     Cluster version is 4.6.0-0.nightly-2020-10-03-051134

$ oc get csv
NAME                                           DISPLAY                  VERSION                 REPLACES   PHASE
clusterlogging.4.6.0-202009240527.p0           Cluster Logging          4.6.0-202009240527.p0              Succeeded
elasticsearch-operator.4.6.0-202009232303.p0   Elasticsearch Operator   4.6.0-202009232303.p0              Succeeded

Comment 10 Giriyamma 2020-10-06 16:15:17 UTC
@Luke I have followed the steps mentioned in the doc https://docs.engineering.redhat.com/display/MULTIARCH/How+To+Test+Red+Hat+ART+Operators and created the CatalogSource as below:

apiVersion: operators.coreos.com/v1alpha1
kind: CatalogSource
metadata:
  name: redhat-operators-art-stage
  namespace: openshift-marketplace
spec:
  sourceType: grpc
  publisher: redhat
  displayName: Red Hat Operators v4.6 Stage
  image: brew.registry.redhat.io/rh-osbs/iib-pub-pending:v4.6

I still see old csv's:
oc get csv
NAME                                           DISPLAY                  VERSION                 REPLACES   PHASE
clusterlogging.4.6.0-202009240527.p0           Cluster Logging          4.6.0-202009240527.p0              Succeeded
elasticsearch-operator.4.6.0-202009232303.p0   Elasticsearch Operator   4.6.0-202009232303.p0              Succeeded

I have also tried with image: registry-proxy.engineering.redhat.com/rh-osbs/iib-pub-pending:v4.6

Comment 12 Giriyamma 2020-10-07 11:23:34 UTC
@Luke Meyer  Below are the operators I got after successfully performed all the steps from the doc https://docs.engineering.redhat.com/display/MULTIARCH/How+To+Test+Red+Hat+ART+Operators

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-10-07-022140   True        False         90m     Cluster version is 4.6.0-0.nightly-2020-10-07-022140

oc get csv
NAME                                           DISPLAY                  VERSION                 REPLACES   PHASE
clusterlogging.4.6.0-202010010620.p0           Cluster Logging          4.6.0-202010010620.p0              Succeeded
elasticsearch-operator.4.6.0-202010010929.p0   Elasticsearch Operator   4.6.0-202010010929.p0              Succeeded

CatalogSource spec:
spec:
  displayName: My Operator Catalog
  image: registry-proxy.engineering.redhat.com/rh-osbs/iib-pub-pending:v4.6
  publisher: grpc
  sourceType: grpc

Comment 13 Luke Meyer 2020-10-07 21:42:53 UTC
Having successfully pushed VPA-operator to stage once, tests began failing, revealing that the CSV name replacement that was supposed to happen to give it a unique name for each build - wasn't matching. So it gets the same name every time which fails the test. https://github.com/openshift/vertical-pod-autoscaler-operator/pull/38 should make the match work. This is required to ship VPA-operator.

Comment 15 Giriyamma 2020-10-09 04:00:15 UTC
Verified this bug, able to get the latest builds for logging operators.

Comment 17 errata-xmlrpc 2020-10-27 16:45:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.