Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1882583 - error on rules page of prometheus UI
Summary: error on rules page of prometheus UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Simon Pasquier
QA Contact: hongyan li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-25 03:45 UTC by hongyan li
Modified: 2020-10-27 16:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:45:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
screen shot (163.53 KB, image/png)
2020-09-25 05:45 UTC, Junqi Zhao
no flags Details
prometheus rules page (109.66 KB, image/png)
2020-09-29 01:01 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift prometheus pull 58 0 None closed Bug 1882583: regenerate web assets 2020-12-23 15:27:19 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:45:45 UTC

Description hongyan li 2020-09-25 03:45:22 UTC
Description of problem:
error on rules page of prometheus UI 

Version-Release number of selected component (if applicable):
prometheus version 2.21.0
OCP 4.6.0-0.nightly-2020-09-24-184015


How reproducible:
always

Steps to Reproduce:
Access prometheus rules UI, get error
https://prometheus-k8s-openshift-monitoring.apps.qe-groupd-0925.qe.devcluster.openshift.com/rules

error executing template rules.html: template: rules.html:84:48: executing "content" at <.GetEvaluationTimestamp.IsZero>: can't evaluate field GetEvaluationTimestamp in type *rules.Group

Actual results:


Expected results:


Additional info:

Comment 1 Junqi Zhao 2020-09-25 05:45:28 UTC
Created attachment 1716532 [details]
screen shot

Comment 3 Junqi Zhao 2020-09-29 00:59:55 UTC
tested with 4.6.0-0.nightly-2020-09-28-125756, no error with prometheus /rules page

Comment 4 Junqi Zhao 2020-09-29 01:01:07 UTC
Created attachment 1717384 [details]
prometheus rules page

Comment 7 errata-xmlrpc 2020-10-27 16:45:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.