Bug 1882752 - Documentation for bare metal workers describes an unsupported feature
Summary: Documentation for bare metal workers describes an unsupported feature
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 4.6.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-25 15:04 UTC by Pierre Prinetti
Modified: 2020-10-27 16:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:45:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4230 0 None closed Bug 1882752: openstack BM: Remove MachineSet on separate subnet 2020-10-05 13:42:23 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:45:51 UTC

Description Pierre Prinetti 2020-09-25 15:04:00 UTC
The documentation about bare metal workers describes how to "Deploy a cluster with VM workers only and add BM workers after"[1].

This use case was designed for supporting OpenStack configurations where:
- The bare metal machines can only exist on a specific provider network
- It is not allowed to create VMs on the specific provider network where BMs exist.

The documentation details how to create a BM MachineSet on a separate subnet, on the provider network.

However, OpenShift on Openstack v4.6 does not support additional MachineSets in separate subnets.

[1]: https://github.com/openshift/installer/blob/master/docs/user/openstack/deploy_baremetal_workers.md#deploy-cluster-with-vm-workers-only-and-add-bm-workers-after

Comment 1 Pierre Prinetti 2020-09-25 15:04:58 UTC
Setting a low severity because the expected resolution entails a change in the documentation only.

Comment 4 David Sanz 2020-10-02 10:12:59 UTC
Verified doc

Comment 7 errata-xmlrpc 2020-10-27 16:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.