Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1882863 - gnome-software 3.38.0 does not list all software in Add-ons
Summary: gnome-software 3.38.0 does not list all software in Add-ons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution-gpg-keys
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException RejectedBlocker
: 1887923 (view as bug list)
Depends On:
Blocks: F33FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2020-09-26 02:03 UTC by Geoffrey Marr
Modified: 2020-10-13 15:22 UTC (History)
11 users (show)

Fixed In Version: distribution-gpg-keys-1.42-1.fc33 distribution-gpg-keys-1.43-1.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-12 21:56:54 UTC
Type: Bug


Attachments (Terms of Use)
picture of Add-ons page in gnome-software after adding repos (52.82 KB, image/png)
2020-09-26 02:03 UTC, Geoffrey Marr
no flags Details
output of "sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info" (8.09 KB, text/plain)
2020-09-26 02:04 UTC, Geoffrey Marr
no flags Details

Description Geoffrey Marr 2020-09-26 02:03:34 UTC
Created attachment 1716747 [details]
picture of Add-ons page in gnome-software after adding repos

Description of problem:
Installed Fedora-Workstation-Live-x86_64-33_Beta-1.3.iso. Booted the system, opened gnome-software, enabled third-party repos and rpmfusion-nonfree-nvidia-driver repo. Refreshed gnome-software cache by going to "Updates" and hitting the refresh button in the top right. Rebooted system, opened gnome-software, went to "Add-ons", and saw that the "Hardware Drivers" tab is missing.

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-x86_64-33_Beta-1.3.iso
gnome-software-3.38.0-2.fc33

How reproducible:
Every time.


Additional info:
"sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info" shows all sorts of NVIDIA packages that could be installed with dnf. See attachment for full output.

Comment 1 Geoffrey Marr 2020-09-26 02:04:03 UTC
Created attachment 1716748 [details]
output of "sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info"

Comment 2 Geoffrey Marr 2020-09-26 02:07:40 UTC
I tried reloading the cache by running "rm -rf ~/.cache/gnome-software" and then reopening gnome-software, but this did not fix the issue.

Comment 3 Fedora Blocker Bugs Application 2020-09-26 02:17:04 UTC
Proposed as a Blocker for 33-final by Fedora user coremodule using the blocker tracking app because:

 Default application functionality

All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test.

Comment 4 Geoffrey Marr 2020-09-28 17:01:37 UTC
Discussed during the 2020-09-28 blocker review meeting: [0]

The decision to delay the classification of this as a blocker bug was made as it's not clear what the scope of this bug is, so it's hard to make a blocker decision at this time.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-09-28/f33-blocker-review.2020-09-28-16.01.txt

Comment 5 Kamil Páral 2020-09-29 10:16:36 UTC
This link should be mentioned, I believe:
https://pcsupport.lenovo.com/ca/en/products/laptops-and-netbooks/thinkpad-p-series-laptops/thinkpad-p53-type-20qn-20qq/solutions/ht511074-enabling-nvidia-proprietary-drivers-on-fedora-linux

The official Lenovo docs show this approach of installing the nvidia driver.

Comment 6 Kamil Páral 2020-09-29 20:08:10 UTC
I tested this in a F32 VM and a F33 VM.

In F32, after enabling the nvidia third-party repository, I can see the driver in Addons->Hardware drivers, and I can also simply find it by searching for "nvidia". PackageKit also sees it:

[kparal@f32 ~]$ pkcon repo-list | grep nvidia
 Enabled    rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver
 Disabled   rpmfusion-nonfree-nvidia-driver-debuginfo RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver Debug
 Disabled   rpmfusion-nonfree-nvidia-driver-source RPM Fusion for Fedora 32 - Nonfree - NVIDIA Driver Source

[kparal@f32 ~]$ pkcon search nvidia | grep -E '(kmod|drv)'
Available    akmod-nvidia-3:450.66-1.fc32.x86_64 (rpmfusion-nonfree-nvidia-driver)
Available    kmod-nvidia-3:450.66-1.fc32.x86_64 (rpmfusion-nonfree-nvidia-driver)
Available    xorg-x11-drv-nvidia-3:450.66-2.fc32.x86_64 (rpmfusion-nonfree-nvidia-driver)
Available    xorg-x11-drv-nvidia-devel-3:450.66-2.fc32.i686 (rpmfusion-nonfree-nvidia-driver)
Available    xorg-x11-drv-nvidia-devel-3:450.66-2.fc32.x86_64 (rpmfusion-nonfree-nvidia-driver)
Available    xorg-x11-drv-nvidia-kmodsrc-3:450.66-2.fc32.x86_64 (rpmfusion-nonfree-nvidia-driver)
Available    xorg-x11-drv-nvidia-libs-3:450.66-2.fc32.i686 (rpmfusion-nonfree-nvidia-driver)
Available    xorg-x11-drv-nvidia-libs-3:450.66-2.fc32.x86_64 (rpmfusion-nonfree-nvidia-driver)


However, the in F33 (after enabling the nvidia third-party repository), gnome-software doesn't show the nvidia driver neither in Addons nor in direct search. PackageKit doesn't see it either:

[kparal@f33 ~]$ pkcon repo-list | grep nvidia
 Enabled    rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver
 Disabled   rpmfusion-nonfree-nvidia-driver-debuginfo RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver Debug
 Disabled   rpmfusion-nonfree-nvidia-driver-source RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver Source

[kparal@f33 ~]$ pkcon refresh force
...

[kparal@f33 ~]$ pkcon search nvidia | grep -E '(kmod|drv)'
[kparal@f33 ~]$

But dnf can find it:

[kparal@f33 ~]$ sudo dnf repolist | grep nvidia
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 33 - Nonfree - NVIDIA Driver

[kparal@f33 ~]$ sudo dnf search nvidia | grep -E '(kmod|drv)'
Last metadata expiration check: 0:01:46 ago on Tue 29 Sep 2020 09:56:39 PM CEST.
akmod-nvidia.x86_64 : Akmod package for nvidia kernel module(s)
kmod-nvidia.x86_64 : Metapackage which tracks in nvidia kernel module for newest kernel
xorg-x11-drv-nvidia.x86_64 : NVIDIA's proprietary display driver for NVIDIA graphic cards
xorg-x11-drv-nvidia-cuda.x86_64 : CUDA driver for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-devel.i686 : Development files for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-devel.x86_64 : Development files for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-kmodsrc.x86_64 : xorg-x11-drv-nvidia kernel module source code
xorg-x11-drv-nvidia-libs.i686 : Libraries for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-libs.x86_64 : Libraries for xorg-x11-drv-nvidia
xorg-x11-drv-nouveau.x86_64 : Xorg X11 nouveau video driver for NVIDIA graphics chipsets


So, either there is some problem in PackageKit and it's filtering out stuff that it shouldn't. Or there is some problem with appstream metadata in F33 version of the repository, which cause PackageKit to ignore the packages. But I can't really determine that, we'll need a desktop person to look into this.

Comment 7 Kalev Lember 2020-09-30 06:32:26 UTC
I just started looking into this and found that packagekitd prints the following warning:

(packagekitd:283789): libdnf-WARNING **: 08:28:09.052: Skipping refresh of rpmfusion-nonfree-nvidia-driver: Failed to download gpg key for repo 'rpmfusion-nonfree-nvidia-driver': Curl error (37): Couldn't read a file:// file for file:///usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33 [Couldn't open file /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33]

(packagekitd:283789): libdnf-WARNING **: 08:28:09.061: Skipping refresh of rpmfusion-nonfree-steam: Failed to download gpg key for repo 'rpmfusion-nonfree-steam': Curl error (37): Couldn't read a file:// file for file:///usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33 [Couldn't open file /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33]

Looks like distribution-gpg-keys is missing the GPG key for the repo.

Comment 8 Adam Williamson 2020-10-05 16:39:29 UTC
I think the fix for this just showed up: https://bodhi.fedoraproject.org/updates/FEDORA-2020-910d76ff81

It's marked as fixing https://bugzilla.redhat.com/show_bug.cgi?id=1885076 , which looks a lot like a dupe of this.

Comment 9 Adam Williamson 2020-10-05 16:47:59 UTC
*** Bug 1885076 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2020-10-05 17:38:57 UTC
FEDORA-2020-910d76ff81 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-910d76ff81

Comment 11 Geoffrey Marr 2020-10-05 19:52:19 UTC
Discussed during the 2020-10-05 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker" and an "AcceptedFreezeException" was made as we don't think this can really count as a violation of the criterion cited, the app's "basic functionality" is working fine, it is just rejecting a repo whose key it can't find, which is correct behavior. However, we definitely want these additional repos to work at release time as they are widely used, so accepted as a freeze exception issue.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2020-10-05/f33-blocker-review.2020-10-05-16.00.txt

Comment 12 Kamil Páral 2020-10-06 13:10:00 UTC
(In reply to Fedora Update System from comment #10)
> FEDORA-2020-910d76ff81 has been submitted as an update to Fedora 33.
> https://bodhi.fedoraproject.org/updates/FEDORA-2020-910d76ff81

This doesn't fix the problem:

$ rpm -q distribution-gpg-keys
distribution-gpg-keys-1.42-1.fc33.noarch
$ pkcon refresh force
...
$ pkcon search nvidia | grep -E '(kmod|drv)'
$ 

The required file is not present:

$ ls /usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33
ls: cannot access '/usr/share/distribution-gpg-keys/rpmfusion/RPM-GPG-KEY-rpmfusion-nonfree-fedora-33': No such file or directory
$ rpm -ql distribution-gpg-keys | grep fedora-33
/usr/share/distribution-gpg-keys/fedora/RPM-GPG-KEY-fedora-33-primary

Comment 13 Fedora Update System 2020-10-06 14:05:02 UTC
FEDORA-2020-910d76ff81 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Adam Williamson 2020-10-06 16:38:18 UTC
Hmmm, yeah, the upstream commit looks strange here: https://github.com/xsuchy/distribution-gpg-keys/commit/df433ba2d077de89625deb276eeb256200ac080c
The commit message says "add rpmfusion 33" but it doesn't actually appear to add any files. I'm not sure what the '2020' thing is about.

Comment 15 Adam Williamson 2020-10-06 16:39:44 UTC
If rpmfusion is doing keys by year not release any more, the repo definition would need changing, I guess...

Comment 16 Miroslav Suchý 2020-10-07 14:27:12 UTC
the 2020 is the right one. There should be symlink
RPM-GPG-KEY-rpmfusion-free-fedora-33-primary -> RPM-GPG-KEY-rpmfusion-free-fedora-2020

I forgot to git-add those files. Mea culpa. I will re-release that. Nice catch Adam and Kamil.

Comment 17 Miroslav Suchý 2020-10-12 12:15:56 UTC
Should be fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2020-0508ca630a

Comment 18 Kamil Páral 2020-10-12 12:17:36 UTC
It needs a freeze exception, so we must not close this.

Comment 19 Kamil Páral 2020-10-12 12:28:19 UTC
With distribution-gpg-keys-1.43-1.fc33 I can verify that gnome-software shows the nvidia driver in search and also in the Addons->Hardware category.

Comment 20 Adam Williamson 2020-10-12 16:22:07 UTC
msuchy: right, expanding on what kparal said - we're in Final freeze right now so updates don't go to stable automatically, they must be manually pushed. I do the push requests using blockerbugs (https://qa.fedoraproject.org/blockerbugs/milestone/33/final/buglist ). That only works if the bug is open and the update that fixes it is marked as fixing the bug, otherwise the system won't "see" the fix and include it in the push request.

I'll edit the update so it's marked as fixing this bug, and then it will be included next time we do a push request and will actually go stable.

Comment 21 Fedora Update System 2020-10-12 16:23:06 UTC
FEDORA-2020-0508ca630a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-0508ca630a

Comment 22 Fedora Update System 2020-10-12 21:56:54 UTC
FEDORA-2020-0508ca630a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Kalev Lember 2020-10-13 15:22:12 UTC
*** Bug 1887923 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.