Bug 188305 - X server crashes in FontFileCompleteXLFD
Summary: X server crashes in FontFileCompleteXLFD
Status: CLOSED DUPLICATE of bug 189461
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-07 19:06 UTC by Jonathan Abbey
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 15:16:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X Crash traceback, the first (51.21 KB, text/plain)
2006-04-07 19:08 UTC, Jonathan Abbey
no flags Details
Another X crash, slightly different in the traceback (70.88 KB, text/plain)
2006-04-07 19:09 UTC, Jonathan Abbey
no flags Details

Description Jonathan Abbey 2006-04-07 19:06:07 UTC
Description of problem:

The X server in Fedora Core 5 (xorg-x11-server-Xorg-1.0.1-9) crashes
periodically, with a traceback seeming to originate in FontFileCompleteXLFD.

I've captured two tracebacks for the crash, which I will include below.

I'm not seeing anything consistent which seems to cause the X server to crash..
I've observed it while working with OpenOffice and while working with Firefox. 
The most recent crash occurred while I was switching between Metacity workspaces.

Again, I don't know that there's any connection.  The crash has happened for me
a half-dozen times at this point, but I've not seen any consistency in when it
happens.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.0.1-9

How reproducible:

Unclear.  Just use X.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Server goes black, all X tasks die, and init restarts X and brings up the Fedora
login screen again.

Expected results:


Additional info:

I've been running on the Xen0 kernel recently, but I can't swear that I haven't
seen this on the standard kernel.

Comment 1 Jonathan Abbey 2006-04-07 19:08:01 UTC
Created attachment 127476 [details]
X Crash traceback, the first

This is a crash I had in X yesterday, from start to finish of the X session.

Comment 2 Jonathan Abbey 2006-04-07 19:09:45 UTC
Created attachment 127477 [details]
Another X crash, slightly different in the traceback

Today's X crash, including everything from the start to finish of the short,
happy life of the Xorg server on my box.

Comment 3 Mike A. Harris 2006-05-23 12:07:01 UTC
The first crash is from a SIGSEGV, which appears to be in the fb layer MMX
code.  The second crash is a SIGILL, (illegal instruction), which seems like
an unrelated issue.

Please try to reproduce this without Xen, to determine if it is an issue
being caused by running under Xen.


Comment 4 Jonathan Abbey 2006-05-23 14:09:28 UTC
I ran on a non-Xen kernel for a couple of weeks without seeing any X crashes,
then ran a bunch of yum updates, and have for the last three days been running
on Xen again without yet seeing an X crash.

I don't know how I'd try to reproduce this, unfortunately.

Comment 5 Mike A. Harris 2006-05-23 15:16:34 UTC

*** This bug has been marked as a duplicate of 189461 ***


Note You need to log in before you can comment on or make changes to this bug.