Bug 18832 - efence complains setlocale() in 2.1.94-3 stomps on memory.
efence complains setlocale() in 2.1.94-3 stomps on memory.
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-10 13:25 EDT by Sam Varshavchik
Modified: 2016-11-24 09:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 19:33:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test program and a gdb post mortem. (3.52 KB, text/plain)
2000-10-10 13:26 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2000-10-10 13:25:36 EDT
The electric fence debugger is complaining that the errata glibc 2.1.94
release's setlocale() is now stomping on memory.  This did not happen in
2.1.92.  See the following attachment.
Comment 1 Sam Varshavchik 2000-10-10 13:26:55 EDT
Created attachment 3984 [details]
test program and a gdb post mortem.
Comment 2 Jakub Jelinek 2000-10-10 16:25:52 EDT
Thanks for the report, I have localized the problem, am now thinking
about best fix. The bug is actually very old, even glibc 2.1.3
has it, so I'm wondering why it did not show up with earlier glibcs
in Efence.
Comment 3 Sam Varshavchik 2000-10-10 17:38:54 EDT
Well, it did not, and I certainly did have the code in question linked against
efence under 2.1.3 and 2.1.92.

efence pads allocated memory to word boundaries, so one possibility is that
previously the stomp didn't go far enough off base to be caught.


Comment 4 Bill Woodward 2000-11-14 19:32:59 EST
Just a quick workaround.  Removing the lines with non-7-bit clean characters out
of /usr/share/locale/locale.alias causes this problem to go away.  Fine for me
since I'm only using en_US.

Note You need to log in before you can comment on or make changes to this bug.