Bug 188322 - SELinux keeps metacity from starting up
SELinux keeps metacity from starting up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Coker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 16:50 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-11 06:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-04-07 16:50:17 EDT
Description of problem:
After a fresh install from the Fedora rawhide tree (04/07/06),
logging in to a graphical session fails. The GNOME splashscreen
appears, then the window manager icon. The session is stuck.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.2.29-4

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora rawhide as of 04/70/06.
2. Login to GNOME from login panel.
  
Actual results:
Login process gets stuck after displaying the splash screen

Expected results:
GNOME session should have launched properly.

Additional info:
In "/tmp/xses-...", the following error message appears:
  "/usr/bin/metacity: error while loading shared libraries:
   libGL.so.1: cannot enable executable stack as shared object
   requires: Permission denied"
After rebooting the system with "enforcing=0", everything works
as expected which confirms an issue with the current SELinux
policy.
Comment 1 Bernard Johnson 2006-04-08 15:58:33 EDT
Same problem here.  The session will eventually start, but you won't like the
results (ie. no window borders, etc.)

Apr  8 13:59:44 localhost kernel: audit(1144526384.633:89): avc:  denied  {
execstack } for  pid=2987 comm="metacity"
scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:unconfined_t:s0 tclass=process

[root@localhost ~]# audit2allow -i /var/log/messages
allow bluetooth_helper_t xdm_t:fd use;
allow bluetooth_helper_t xdm_t:fifo_file write;
allow hald_t sysctl_vm_t:dir write;
allow unconfined_t self:process execstack;
Comment 2 Joachim Frieben 2006-04-11 06:17:01 EDT
Fixed in "mesa-6.5-3" which, of course, was the better approach.
Comment 3 Russell Coker 2006-04-11 06:40:55 EDT
Closing as it's not a bug in SE Linux policy.

Note You need to log in before you can comment on or make changes to this bug.