Bug 188324 - No eth interface numbering, when ONBOOT=no.
No eth interface numbering, when ONBOOT=no.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 16:51 EDT by Thomas Steudten
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 02:27:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Steudten 2006-04-07 16:51:28 EDT
Description of problem:

On my laptop I've 3 interfaces:
eth0: docking station
eth1: laptop
eth2: wireless

Only eth0 is set to ONBOOT=yes. In docking station everything works as expected.
But without docking station, eth0 from above is not there.
When I boot the system, eth1 is down, that's ok (ONBOOT=no), but
the wireless interface is eth0, because it's down (ONBOOT=no), but the
module is loaded. The wireless interface should be eth2, not eth0, so that
iwlist, iwconfig can be used and the config file is also ifcfg-eth2.
The rename is only done, in ifup, when the ONBOOT is set to yes, but it should
also take place, when the interface is down (ONBOOT=no), so that the interface
numbering is the same like in normal system state. 
Simply check the MAC address and DEVICE name - this should match, independently
if the interface is down or up.

Version-Release number of selected component (if applicable):
initscripts-8.31.1-1

How reproducible:
Use eth0, eth1 and eth2. Only eth0 is ONBOOT=yes.
Remove eth0 and reboot. Now eth2 is eth0, not eth2.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
eth0 is wireless.

Expected results:
eth2 should be the wireless interface.

Additional info:
Comment 1 Bill Nottingham 2006-04-07 23:31:48 EDT
Please try 8.31.2-1 from updates-testing.
Comment 2 Thomas Steudten 2006-04-12 07:21:01 EDT
I tried it, and the interface numbering scheme seems to be ok. Thanks.

Note You need to log in before you can comment on or make changes to this bug.