Bug 188329 - Fedora can't get past the second stage bootstrap after a fresh install
Fedora can't get past the second stage bootstrap after a fresh install
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
5
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 18:54 EDT by Trevor Davenport
Modified: 2008-03-11 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 12:56:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yaboot Config File (446 bytes, text/plain)
2006-04-07 18:54 EDT, Trevor Davenport
no flags Details
ofboot.b from /dev/sda2 (3.08 KB, text/plain)
2006-04-07 19:16 EDT, Trevor Davenport
no flags Details
Contents of /proc/device-tree (120.36 KB, application/octet-stream)
2006-04-08 18:54 EDT, Trevor Davenport
no flags Details
Contents of /proc/device-tree on single 1.6GHz G5 PowerMac (20.46 KB, application/octet-stream)
2006-05-10 21:14 EDT, Ian Romanick
no flags Details
Output of new ofpath (462 bytes, text/plain)
2006-05-11 13:09 EDT, Ian Romanick
no flags Details

  None (edit)
Description Trevor Davenport 2006-04-07 18:54:16 EDT
On a PowerMac3 G4 500 mhz with a seagate 17gb scsi hard drive, after installing
the booting hangs once the loading second stage bootstrap appears. 

 
running nvsetenv boot-device prints:
# nvsetenv boot-device
boot-device=/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@4/@0:2,\\:tbxi


running ybin -v prints:
ybin: Installing first stage bootstrap /usr/lib/yaboot/ofboot onto /dev/sda2...
ybin: Installing primary bootstrap /usr/lib/yaboot/yaboot onto /dev/sda2...
ybin: Installing /etc/yaboot.conf onto /dev/sda2...
ybin: Setting attributes on ofboot...
ybin: Setting attributes on yaboot...
ybin: Setting attributes on yaboot.conf...
ybin: Blessing /dev/sda2 with Holy Penguin Pee...
ybin: Updating OpenFirmware boot-device variable in nvram...

In OpenFirmware running devalias prints the hd alias as:
hd    /pci@f2000000/@d/mac-io@7/ata/4@1f000/disk@0
Comment 1 Trevor Davenport 2006-04-07 18:54:16 EDT
Created attachment 127489 [details]
Yaboot Config File
Comment 2 Trevor Davenport 2006-04-07 19:04:32 EDT
The ofboot option in the config file was only added in an effort to fix the
problem but it had no effect.  I also tried hd:2 but both just stop at the
loading second stage bootstrap..... prompt and then eventually bring up the
purple mac icon withe the question mark.
Comment 3 Trevor Davenport 2006-04-07 19:16:01 EDT
Created attachment 127490 [details]
ofboot.b from /dev/sda2
Comment 4 Trevor Davenport 2006-04-08 15:34:41 EDT
After much experimenting I think I know what is happening though I'm still not
sure what to do to fix it.  I found this through using and ubuntu live cd and
running ybin from it would always make the system bootable so I used the ofpath
command from the live to show the OF path to the boot partition which gave me:

/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@4,1/@0:2 

but inside of fedora then ofpath returns 

/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@4/@0:2

it is missing the ,1 after the @4.  manually going into OF and typing:

 boot /pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@4,1/@0:2,\\:yaboot 

does indeed start yaboot just fine and the system boots normally but if I type:

boot /pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@4,1/@0:2,\\:tbxi 

it goes to the first stage bootstrap as expected but then gets an error loading
yaboot that says it can't open

/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@4,1/@0:2,\\yaboot 

which is exactly the same as above except there is no : before yaboot.  What I
think is happening is that running ybin in fedora sets the boot-device
incorrectly because for some reason it is getting a path that doesn't work and
then it also can't find yaboot after the first stage because that path is wrong.
 So the system will work after i've run ybin from the live cd ( it doesn't work
if I use rescue mode from the fedora cd) until the next kernel install and it
will break again.
Comment 5 Paul Nasrat 2006-04-08 16:44:07 EDT
Sounds like ofpath is buggy on your setup.  Please provide a tarball of
/proc/device-tree.  What version of yaboot does ubuntu ship with? Can you also
attach the ofpath from ubuntu.
Comment 6 Paul Nasrat 2006-04-08 16:50:04 EDT
Actually I have the ubuntu patches, what does /proc/modules on your machine
contain (I still want /proc/device-tree)
Comment 7 Trevor Davenport 2006-04-08 18:54:53 EDT
Created attachment 127515 [details]
Contents of /proc/device-tree
Comment 8 Trevor Davenport 2006-04-08 18:56:42 EDT
Contents of /proc/modules

# cat /proc/modules
r128 48644 1 - Live 0xf21b2000
drm 85560 2 r128, Live 0xf2555000
ppdev 11364 0 - Live 0xf2121000
autofs4 25124 1 - Live 0xf216c000
hidp 20352 2 - Live 0xf2166000
rfcomm 46484 0 - Live 0xf21a5000
l2cap 29728 10 hidp,rfcomm, Live 0xf214c000
bluetooth 61696 3 hidp,rfcomm,l2cap, Live 0xf2155000
sunrpc 188488 1 - Live 0xf2175000
ip_conntrack_ftp 8688 0 - Live 0xf2128000
ip_conntrack_netbios_ns 2976 0 - Live 0xf2116000
ipt_REJECT 6560 1 - Live 0xf2125000
xt_state 2112 9 - Live 0xf211f000
ip_conntrack 65232 3 ip_conntrack_ftp,ip_conntrack_netbios_ns,xt_state, Live
0xf2131000
nfnetlink 7896 1 ip_conntrack, Live 0xf2118000
xt_tcpudp 3488 11 - Live 0xf211b000
iptable_filter 3200 1 - Live 0xf2109000
ip_tables 14696 1 iptable_filter, Live 0xf2111000
x_tables 16004 4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables, Live 0xf210c000
ipv6 307364 12 - Live 0xf25af000
lp 15376 0 - Live 0xf24a3000
parport_pc 41460 0 - Live 0xf24b9000
parport 45936 3 ppdev,lp,parport_pc, Live 0xf24ac000
ohci1394 42308 0 - Live 0xf225b000
ieee1394 432896 1 ohci1394, Live 0xf24ea000
ohci_hcd 25884 0 - Live 0xf2246000
sg 42816 0 - Live 0xf2223000
tulip 58116 0 - Live 0xf2236000
sungem 38660 0 - Live 0xf2218000
sungem_phy 9952 1 sungem, Live 0xf20bc000
dm_snapshot 21036 0 - Live 0xf20b5000
dm_zero 2176 0 - Live 0xf104b000
dm_mirror 25876 0 - Live 0xf20ad000
dm_mod 67616 6 dm_snapshot,dm_zero,dm_mirror, Live 0xf106d000
ext3 156808 2 - Live 0xf21f0000
jbd 78068 1 ext3, Live 0xf20c7000
sym53c8xx 85208 2 - Live 0xf1057000
scsi_transport_spi 28128 1 sym53c8xx, Live 0xf102f000
sd_mod 21472 3 - Live 0xf1037000
scsi_mod 172252 4 sg,sym53c8xx,scsi_transport_spi,sd_mod, Live 0xf2081000
Comment 9 Ian Romanick 2006-05-05 18:52:12 EDT
I see similar behavior on a 1.6GHz G5 PowerMac.  Could this be related to a
particular firmware revision?  I guess that wouldn't explain why the problem
isn't seen on Ubutnu. :(
Comment 10 Paul Nasrat 2006-05-10 14:10:48 EDT
Ian - can you attach /proc/device-tree for your system too.  It's ofpath bug but
a different one for your system.
Comment 11 Ian Romanick 2006-05-10 21:14:10 EDT
Created attachment 128867 [details]
Contents of /proc/device-tree on single 1.6GHz G5 PowerMac
Comment 12 Paul Nasrat 2006-05-10 21:50:45 EDT
Can you also see what

http://people.redhat.com/pnasrat/ofpath 

gives as output for

ofpath /dev/sda
ofpath /dev/sdb

I'm hoping the merge I made from ubuntu's patchset upstream should fix this.
Comment 13 Ian Romanick 2006-05-11 13:09:39 EDT
Created attachment 128903 [details]
Output of new ofpath

Both /sbin/ofpath and your updated ofpath report "/disk@0:" for /dev/sda, and I
don't have a /dev/sdb. :)  I've attached the output of 'ofpath --debug
/dev/sda' just in case there's useful information there.
Comment 14 Trevor Davenport 2006-07-25 12:56:38 EDT
ofpath /dev/sda
/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@2/@0:

Comment 15 Trevor Davenport 2006-07-25 13:14:29 EDT
with the patched ofpath the boot device is getting set to:

boot-device=/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@2/@0:2,\\:tbxi

and continues to have a booting problems.  After running ybin from the ubuntu
live cd it gets set to. 

boot-device=/pci@f2000000/pci-bridge@d/ATTO,ExpressPCIProUL2D@2,1/@0:2,\\:tbxi

hope this helps.


P.S.  Sorry for such a long time between replying to the bug mail...seems i
didn't get any bug mail about it for some reason and didn't know there was
anything else happening until I decided to check today...cheers
Comment 16 Red Hat Bugzilla 2007-08-21 01:23:29 EDT
User pnasrat@redhat.com's account has been closed
Comment 17 Trevor Davenport 2007-08-21 12:49:59 EDT
I am no longer employed where i am able to test or provide anymore information
regarding this bug.

Note You need to log in before you can comment on or make changes to this bug.