This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188330 - No audio with snd-intel8x0 and 2.6.16-1.2080_FC5
No audio with snd-intel8x0 and 2.6.16-1.2080_FC5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 19:22 EDT by Austin Foxley
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 01:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsound.log (10.06 KB, text/plain)
2006-04-07 19:22 EDT, Austin Foxley
no flags Details
output of 'cat /proc/asound/cards' (114 bytes, application/octet-stream)
2006-04-10 13:25 EDT, Austin Foxley
no flags Details
output of lspci -vn (5.09 KB, application/octet-stream)
2006-04-10 13:25 EDT, Austin Foxley
no flags Details
scsound log for msi k8n platinum neo4 mb (3.95 KB, application/x-gzip)
2006-04-18 17:08 EDT, Petr Hrasky
no flags Details
scsound.log (6.80 KB, text/plain)
2006-04-18 23:38 EDT, Richard Ryniker
no flags Details
log after running system-config-soundcard (10.24 KB, text/plain)
2006-06-05 16:07 EDT, Maxwell Bottiger
no flags Details

  None (edit)
Description Austin Foxley 2006-04-07 19:22:09 EDT
Description of problem:
No sound with snd-intel8x0 and 2.6.16-1.2080_FC5

Version-Release number of selected component (if applicable):
Not entirely sure this is an alsa problem. I have seen people having problems
with alsa in this kernel though.

How reproducible:
Fresh install of fc5, run system-config-soundcard. Press play, and no sound is
heard.

Actual results:
No sound


Expected results:
Guitar test sound should be played


Additional info:
I had a problem with this card in fc4, but fixed it by blacklisting the
snd-intel8x0m module. This doesn't help either way in fc5.
Comment 1 Austin Foxley 2006-04-07 19:22:10 EDT
Created attachment 127491 [details]
scsound.log
Comment 2 Martin Stransky 2006-04-08 05:33:03 EDT
if you want to use another driver, substitute all snd-intel8x0 in
/etc/modprobe.conf to new driver name (did you use snd-hda-intel?)

btw. what card do you have? Could you attach /proc/asound/cards and output of
"lspci -vn"?

Another way is checking new drivers, how-to is here:
http://people.redhat.com/stransky/alsa
Comment 3 Austin Foxley 2006-04-10 13:23:40 EDT
I tried snd-hda-intel like you said and there was no change, and lsmod still
showed that snd-intel8x0 was loaded.

I have a Conexant AC-97 (intel clone i'm guessing). It's a poor card, but it's
what came in the (gateway) laptop.

Attached are the outputs you asked for.

I will try your new drivers, as soon as I get a chance and get back to you.
Comment 4 Austin Foxley 2006-04-10 13:25:05 EDT
Created attachment 127558 [details]
output of 'cat /proc/asound/cards'
Comment 5 Austin Foxley 2006-04-10 13:25:40 EDT
Created attachment 127559 [details]
output of lspci -vn
Comment 6 Austin Foxley 2006-04-10 18:03:13 EDT
I tried the devel drivers, and no change in behaviour. 

Maybe relevant output of: dmesg | grep "ICH"
PCI quirk: region 1000-107f claimed by ICH6 ACPI/GPIO/TCO
PCI quirk: region 1180-11bf claimed by ICH6 GPIO
ICH6: IDE controller at PCI slot 0000:00:1f.1
ICH6: chipset revision 4
ICH6: not 100% native mode: will probe irqs later
Comment 7 Stefano Mingoli 2006-04-11 14:39:12 EDT
Same problem on a packard bell a8500 notebook. Does not work on FC4 either.
Comment 8 Petr Hrasky 2006-04-18 17:08:23 EDT
Created attachment 127951 [details]
scsound log for msi k8n platinum neo4 mb
Comment 9 Richard Ryniker 2006-04-18 23:38:32 EDT
Created attachment 127968 [details]
scsound.log

Similar problem, with Tyan Thunder K8WE S2895 motherboard, which also uses
the on-board nVidia Corporation CK804 AC'97 Audio Controller used on P.
Hrasky's system.  While the attached scsound.log file appears to indicate
alsa-lib-1.0.11-3.rc2.2 was installed twice(!), these are actually 32-bit and
64-bit versions of alsa-lib (both were installed during the original FC5
installation.)
Comment 10 Petr Hrasky 2006-04-21 18:16:35 EDT
I did strace an found out the alsa tools want to open alsa.conf 
in /usr/share/alsa where there is none. So I copied it over from /etc/alsa and 
here I go - sound is back! So either the tools should look to /etc/alsa or 
the /usr/share/alsa should be link to /etc/alsa?
Comment 11 Austin Foxley 2006-04-21 18:46:37 EDT
I added the link from /usr/share/alsa to /etc/alsa and my sound is back too!

Thanks a ton.
Anybody that didn't work for?


(In reply to comment #10)
> I did strace an found out the alsa tools want to open alsa.conf 
> in /usr/share/alsa where there is none. So I copied it over from /etc/alsa and 
> here I go - sound is back! So either the tools should look to /etc/alsa or 
> the /usr/share/alsa should be link to /etc/alsa?
Comment 12 Martin Stransky 2006-04-25 03:52:17 EDT
You don't have /usr/share/alsa link after install? It should be here, I'll check it.
Comment 13 Matthias Saou 2006-04-27 08:04:43 EDT
$ ls -l /usr/share/alsa/speaker-test/sample_map.csv
-rw-r--r-- 1 root root 118 Apr  6 11:05 /usr/share/alsa/speaker-test/sample_map.csv
$ rpm -qf /usr/share/alsa/speaker-test/sample_map.csv
alsa-utils(0:1.0.11-5.rc2).i386

And here, /usr/share/alsa/ is a directory, thus no way it can easily be replaced
by a symlink.

$ rpm -qf /usr/share/alsa
file /usr/share/alsa is not owned by any package

On my FC5, still no sound, but stracing mpg321 I see it stat'ing and opening
many files in /etc/alsa/ but nothing under /usr/share/alsa/ anyway.
Comment 14 gdelx001 2006-06-01 22:19:15 EDT
Like Richard Ryniker, have Tyan 2895 motherboard, and non-working sound.  At one
point in FC5 kernel evolution (can't quite remember what update it was, but
pre-2080) sound worked.  Now on 2.6.16-1.2122_FC5, and it still doesn't work.

Files and links mentioned elsewhere in this bug seem to be in place.  aplay
seems to be hung in a poll call, according to strace, and I'm wondering if
something like an interrupt is not properly enabled on the NVIDIA chipset to
permit progress.


 
Comment 15 Maxwell Bottiger 2006-06-05 10:24:17 EDT
I'm facing this same problem, but changing the location of my alsa.conf file
hasn't done anything to help this out.  What I have noticed though is that I can
play audio as root, but not as myself.  When I try to play anything as a regular
user I get something like this:

[bottiger@golbez alsa]$ play ~/Music/Rancid/Let\\\'s\ Go/01\ -\ Nihilism.ogg
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_card_driver
returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_concat returned
error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_refer returned
error: No such device
ALSA lib conf.c:3961:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
sox: Failed writing default: cannot open audio device
Comment 16 Martin Stransky 2006-06-05 10:32:57 EDT
(In reply to comment #15)
> I'm facing this same problem, but changing the location of my alsa.conf file
> hasn't done anything to help this out.  What I have noticed though is that I can
> play audio as root, but not as myself.  When I try to play anything as a regular
> user I get something like this:
> 
> [bottiger@golbez alsa]$ play ~/Music/Rancid/Let\\\'s\ Go/01\ -\ Nihilism.ogg
> ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
> ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_card_driver
> returned error: No such device
> ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
> ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_concat returned
> error: No such device
> ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
> ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_refer returned
> error: No such device
> ALSA lib conf.c:3961:(snd_config_expand) Evaluate error: No such device
> ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
> sox: Failed writing default: cannot open audio device

Could you please run system-config-soundcard and attach /root/scsound.log?

Comment 17 Maxwell Bottiger 2006-06-05 16:07:21 EDT
Created attachment 130537 [details]
log after running system-config-soundcard

Here you go!
Comment 18 Bevan Bennett 2006-06-28 14:22:47 EDT
This sounds similar to what I've been seeing recently (the past few months). I
manage ~25 FC4 desktops and some update along the line (I can't say exactly
which because I don't use audio that often) made sound on every system go away.
 I've tried FC5 on a test system, but that didn't make any difference.

/proc/asound/cards says:
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebfc000 irq 16

lsmod shows that snd-hda-intel is loaded.
This system is running:
2.6.16-1.2115_FC4smp
alsa-lib-1.0.10-3.FC4
alsa-utils-1.0.10-1.FC4

I'll try the 1.0.11 ALSA again, just in case.
Comment 19 Matthias Saou 2006-06-29 04:35:18 EDT
I managed to fix my problem : I was having nothing but silence, but no errors
whatsoever with the 2.6.16-1.2133_FC5 kernel. I installed the latest ALSA kernel
modules package from atrpms.net, and all worked fine again!

BTW, I saw that 2.6.17-1.2139_FC5 was out, maybe that will fix the problem if
the included ALSA modules were updated in 2.6.17.
Comment 20 Bevan Bennett 2006-06-29 11:49:15 EDT
2.6.17 (along with alsa-libs-1.0.11) has fixed the problem for me.
Comment 21 Matthias Saou 2006-07-25 09:41:00 EDT
For me too, those updates made the sound work again. Someone might want to close
this bug unless others are still having problems.

Note You need to log in before you can comment on or make changes to this bug.