Bug 188334 - "Custom widget creation failed"
"Custom widget creation failed"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gpp (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 19:58 EDT by David Kaplan
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 11:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2006-04-07 19:58:07 EDT
Description of problem:
I run gnome-photo-printer and on the printer and paper tabs the only thing that 
appears is "[custom widget creation failed]".

The following error text is spit out to the terminal:

$ gnome-photo-printer

(gnome-photo-printer:23332): libglade-WARNING **: could not find widget creation
function

(gnome-photo-printer:23332): libglade-WARNING **: could not find widget creation
function
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer _128.114.68.43
could not be loaded.

(gnome-photo-printer:23332): GnomePrintCupsPlugin-WARNING **: iconv does not
support ppd character encoding: ISOLatin1, trying CSISOLatin1
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer Stylus_CX4600
could not be loaded.
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer rippleprint
could not be loaded.
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer
hp_LaserJet_2430_[F97305] could not be loaded.

(gnome-photo-printer:23332): GnomePrintCupsPlugin-WARNING **: iconv does not
support ppd character encoding: MacStandard, trying CSISOLatin1
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer
EMSA232_on_128.114.68.64 could not be loaded.
GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer francisco could
not be loaded.



Version-Release number of selected component (if applicable):
gpp-0.6.5-3.fc5

How reproducible:
always

Steps to Reproduce:
1.gnome-photo-printer
2.
3.
  
Actual results:
two tabs inactivated making program useless

Expected results:
should show a list of printers and papers

Additional info:
This worked for FC3, but now it doesn't.  However, I think this has more to do
with the network setup - I am on a network with lots of shared printers and it
seems to be having problems getting the PPD for some of them and failing as a
result - perhaps these printers should just be excluded from the list or marked
as not available.
Comment 1 Matt Domsch 2006-04-10 11:42:38 EDT
I've forwarded this report to the gpp author, sv@fogman.de for comment.
Comment 2 Armijn Hemel 2006-07-03 05:44:14 EDT
Regarding the fact that it is something related to networked printers, I can
tell you that it's not. I'm here on a system with a USB printer and I have
exactly the same problem. In the paper and printer tab I get the same error.
Comment 3 Matt Domsch 2006-07-03 10:18:56 EDT
I've been in communication with the upstream author.  He's got a fix (1 line 
in configure.ac he claims), but I haven't received a new build from him yet.  
Soon as I get it, I plan to release an update for FC-5 and -devel branches.
Comment 4 Matt Domsch 2006-07-08 11:43:04 EDT
0.6.6-1 released fixes this.  Building now.

Note You need to log in before you can comment on or make changes to this bug.