Bug 188337 - Game gets progressively slower/stuttery on my machine
Game gets progressively slower/stuttery on my machine
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: worminator (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 00:49 EDT by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-02 16:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ignacio Vazquez-Abrams 2006-04-08 00:49:25 EDT
As I proceed throught the first few screenfuls in the game it gets less and less
responsive, with the screen updating only every several seconds or so by the
time I get to the lava. It doesn't show all the action in between, it appears to
take "freeze frames" of the action at each point in time.
Comment 1 Hans de Goede 2006-04-08 02:29:04 EDT
What kinda machine are you running this on? And at what resolution? It sounds
like you're experiencing high frameskips. Worminator isn't programmed all that
effective I guess the later levels are more cpu intensive which could explain
this. Try running at a lower res and / or without FSAA.

Have you tried saving, exiting, restarting and loading again? If there really is
a bug I would expect this to fix it for a while and then for performance to
degrade slowly again.
Comment 2 Ignacio Vazquez-Abrams 2006-04-08 02:50:09 EDT
I'm running it on a Sempron 2200+ at 640x480x256 with FSAA disabled. I don't
know anything about the later levels since this happens on the very first one.
Comment 3 Ignacio Vazquez-Abrams 2006-04-08 02:51:45 EDT
Oh, and saving and loading didn't help, since "slowly" is not a phrase I'd use
to describe the speed at which this happens. It's more like "unbelievably quickly".
Comment 4 Hans de Goede 2006-04-08 03:15:55 EDT
Ok, I think I understand your problem now, right in the first level after a few
seconds of playing it becomes slow, correct?

I've tried it here (again) but I see no such thing. Worminator tries to be nice
to the CPU, do you have any other programs running that could potentially steal
CPU time from it?
Comment 5 Ignacio Vazquez-Abrams 2006-04-08 03:56:08 EDT
I am running other things in the background (gaim, FF, httpd, etc.), but
certainly nothing CPU-intensive.
Comment 6 Hans de Goede 2006-04-08 05:14:21 EDT
Hmm,

Could you run worminator in windowed mode with a top next to it and see how much
cpu it is getting / using?
Comment 7 Ignacio Vazquez-Abrams 2006-04-08 05:40:47 EDT
It starts off at about 40% (which seems rather excessive given that it's a
side-scroller) and shoots up to 100% very quickly.
Comment 8 Hans de Goede 2006-04-08 05:48:20 EDT
weird any chance you could test it on another machine? Is the 100% all used by
worminator or is much of it used by the X-server?
Comment 9 Ignacio Vazquez-Abrams 2006-04-14 07:45:05 EDT
I tried it under VMware but it ended up locking up the game completely in there.
All the CPU time is allocated to worminator.
Comment 10 Hans de Goede 2006-04-15 04:28:40 EDT
VMware doesn't exactly count as another machine. I'll try this at work (which is
another machine) to see if I can reproduce it there, but I've tested worminator
at work before and found no problems, so don't count on it.

In the mean time a few questions for you:
-any chance you can test it on a really other machine
-when you say 100% cpu usage is all cpu used by worminator or is some of the
 CPU used by X and howmuch is used by X?
-any chance you know howto compile with profiling and run it under the profiler?
Comment 11 Hans de Goede 2006-04-24 17:29:46 EDT
I've been able to sortof reproduce this and I think I've found the cause, I just
commited this to Fedora Extras CVS:
* Mon Apr 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 3.0R2.1-3
- Limit the framerate to 80 instead of trying to reach 160 fps,
  hopefully this fixes bug 188337.

3.0R2.1-3 should show up on a mirror near you soon, please test and if it fixes
this close this bug.
Comment 12 Hans de Goede 2006-05-02 16:01:37 EDT
Closing as WORKSFORME because of lack of responce, if you decide to test this
after all let me know the results please.

Note You need to log in before you can comment on or make changes to this bug.