Bug 188353 - ldap authentication not working in httpd-2.2.0-5.1.2
ldap authentication not working in httpd-2.2.0-5.1.2
Status: CLOSED DUPLICATE of bug 188073
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Depends On:
  Show dependency treegraph
Reported: 2006-04-08 06:31 EDT by jay dwyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-10 08:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jay dwyer 2006-04-08 06:31:29 EDT
Description of problem:

configuring ldap authentication fails.

Version-Release number of selected component (if applicable):


How reproducible:

consistently reproducible with and without ssl on the same httpd instance.

another virtual host on this instance is happily serving up subversion
repository over ssl with a .htpasswd auth backend.

ldap just dont wanna work.

Steps to Reproduce:
1. configure httpd with a virtual host requiring ldap auth for given resources,
see below
2. navigate to the http(s) url
3. enter credentials.
4. blank page with wierd http/0.9 response code comes back.
Actual results:

submit request to httpd with basic auth params, and regardless of the contents (
ie: invalid credentials, etc), the request comes back with basically empty result.

if you navigate to a known absolute file path, an empty file is returned.

headers in the response are:

HTTP/0.9 200 OK 

[Sat Apr 08 20:26:54 2006] [notice] child pid 4912 exit signal Segmentation
fault (11)

( one line in log for each request )

Expected results:

authentication should proceed and the resource(s) should be presented as expected

Additional info:

using subversion over ssl with ldap authentication against an openldap 2.1
server on the local network.

full VirtualHost entry: ( names changed to protect the guilty :) )

<VirtualHost *:80>
        ServerAdmin jasond@hotmagna.com
        ServerName actual.virtual.host.com
        ServerAlias alias.virtual.host.com

        DocumentRoot /var/www/actual.virtual.host.com
        DirectoryIndex index.html index.html.var
        AddHandler type-map var

        <location /repository>

                Order allow,deny
                Allow from all
                DAV svn
                SVNPath /usr/local/subversion/repository
                SVNAutoversioning on

                AuthBasicProvider ldap
                AuthType Basic
                AuthName "HotMagna User Required"
                AuthzLDAPAuthoritative off
                AuthLDAPBindDN  XXXXXXX
                AuthLDAPBindPassword XXXXXXX

                require valid-user

            ErrorLog /var/log/httpd/actual-error.log
            # Possible values include: debug, info, notice, warn, error, crit,
            # alert, emerg.
            LogLevel warn
            CustomLog /var/log/httpd/actual.log combined
Comment 1 Joe Orton 2006-04-10 08:04:53 EDT

*** This bug has been marked as a duplicate of 188073 ***

Note You need to log in before you can comment on or make changes to this bug.