Bug 188361 - Xen's "xm save" command fails
Xen's "xm save" command fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Brian Brock
http://lists.xensource.com/archives/h...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 10:08 EDT by Dave Ludlow
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: xen-3.0.1-5.FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 10:59:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to clear the file descriptors flag when saving the domain (704 bytes, patch)
2006-04-08 10:08 EDT, Dave Ludlow
no flags Details | Diff

  None (edit)
Description Dave Ludlow 2006-04-08 10:08:26 EDT
Description of problem:
The xen-3.0.1-cloexec.patch introduces a regression that breaks the "xm save"
command - or more specifically, the xc_save program that it calls.

The discussion at the URL listed sums it up.  Either the cloexec patch needs to
be removed or the close-on-exec flag needs to be cleared in XendCheckpoint.py.

Version-Release number of selected component (if applicable):
3.0.1-4

How reproducible:
Every time

Steps to Reproduce:
1.Execute "xm save domain filename" on a running domain
  
Actual results:
An error is returned and the following goes into xend.log:
Unable to get platform info.: 9 at XendCheckpoint:227

Expected results:
The domain's state and config should be saved to the file.

Additional info:
The migrate command is also broken as a dependency.
I'm not related to the mailing list thread in the URL, it's something I found
while troubleshooting.  I have confirmed that applying the attached patch and
rebuilding the RPM fixes the bug.
Comment 1 Dave Ludlow 2006-04-08 10:08:26 EDT
Created attachment 127506 [details]
Patch to clear the file descriptors flag when saving the domain
Comment 2 Rik van Riel 2006-04-10 11:56:08 EDT
Thanks for the patch.  Daniel, want to add this to our RPM?
Comment 3 JM 2006-04-17 09:19:44 EDT
"xm migrate" calls "xm save" and so "xm migrate" fails too.
Comment 4 Daniel Veillard 2006-04-18 13:06:53 EDT
Okay, reproduced and confirmed the fix, I'm pushing xen-3.0.1-5 to rawhide
and xen-3.0.1-5.FC5 to FC5 testing later.
For migrate it's a different problem !

  thanks !

Daniel
Comment 5 Daniel Veillard 2006-11-02 10:59:44 EST
xen-3.0.1-5.FC5 has been released for a long time now, fixed there.
W.r.t. migration the last time I tried one month ago this worked just fine,
with a pre 3.0.3 release.

Daniel

Note You need to log in before you can comment on or make changes to this bug.