Bug 1883621 - snapd apps won't run or crash on launch
Summary: snapd apps won't run or crash on launch
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: snapd
Version: 33
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Zygmunt Krynicki
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-29 17:52 UTC by itrymybest80
Modified: 2021-11-30 16:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-30 16:28:36 UTC
Type: Bug


Attachments (Terms of Use)

Description itrymybest80 2020-09-29 17:52:58 UTC
Description of problem: i can install snapd on my system and apps, but on completion it will return with the following error message: "WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement" and my applications won't launch or crash on launch.


Version-Release number of selected component (if applicable): snapd-2.45.3.1-1.fc33.x86_64


How reproducible: always


Steps to Reproduce:
1. install snapd on your fedora 33 beta system.
2. install and/or try to launch one of your snapd apps.


Actual results: snapd installation will give you a warning and snapd apps will either not run or crash.


Expected results: snapd apps launch like in previous versions of fedora.

Comment 1 itrymybest80 2020-09-30 11:45:26 UTC
project error

Comment 2 itrymybest80 2020-10-01 00:07:02 UTC
I tried a bunch more snapd apps and run into similar problems. I did reboot after installing snapd and ran hello-world to test, where I got my first warning.

snap list
Name               Version                     Rev   Tracking       Publisher     Notes
chromium           85.0.4183.121               1328  latest/stable  canonical✓    -
core               16-2.46.1                   9993  latest/stable  canonical✓    core
core18             20200724                    1885  latest/stable  canonical✓    base
core20             20                          634   latest/stable  canonical✓    base
foliate            2.4.2                       1119  latest/stable  johnfactotum  -
gnome-3-28-1804    3.28.0-17-gde3d74c.de3d74c  128   latest/stable  canonical✓    -
gnome-3-34-1804    0+git.3556cb3               60    latest/stable  canonical✓    -
gtk-common-themes  0.1-36-gc75f853             1506  latest/stable  canonical✓    -
hello-world        6.4                         29    latest/stable  canonical✓    -
losslesscut        3.22.3                      35    latest/stable  mifino        -
xonotic            0.8.2                       53    latest/stable  snapcrafters  -
yuzu               0-394                       104   latest/stable  nightmayr     -

chromium
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
[13347:13347:1001/020349.706270:ERROR:browser_main_loop.cc(1417)] Unable to open X display.


foliate
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
Cannot get default EGL display: EGL_BAD_PARAMETER
WaylandCompositor requires eglCreateImage and eglDestroyImage.
Nested Wayland compositor could not initialize EGL


losslesscut
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
(losslesscut:13963): Gtk-WARNING **: 02:05:20.967: cannot open display: :0


xonotic
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
Game is Xonotic using base gamedir data
gamename for server filtering: Xonotic
Xonotic Linux 22:06:02 Mar 31 2017 - release
Current nice level is below the soft limit - cannot use niceness
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
Quake Error: Failed to init SDL video subsystem: No available video device


yuzu
WARNING: cgroup v2 is not fully supported yet, proceeding with partial confinement
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.xcb: could not connect to display :0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
Avbruten (SIGABRT) (minnesutskrift skapad)

Comment 3 Maciek Borzecki 2020-10-01 06:15:54 UTC
The warning you see is unrelated to the issue. I suspect you are running a wayland session, all the snaps that you tired seem to be expecting/trying to use X11. Is Xwayland running?

Comment 4 itrymybest80 2020-10-01 15:07:52 UTC
I'm currently logged in to the default Fedora 33 gnome/wayland session on my system.

echo $XDG_SESSION_TYPE
wayland

echo $WAYLAND_DISPLAY
wayland-0

/usr/bin/gnome-shell --wayland --display-server
(gnome-shell:25361): mutter-WARNING **: 17:02:27.628: Failed to create backend: Could not take control: GDBus.Error:System.Error.EBUSY: Device or resource busy

lspci -k | grep -A 2 VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] (rev e7)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device 3417
Kernel driver in use: amdgpu

Comment 5 Maciek Borzecki 2020-10-01 19:00:46 UTC
That's interesting. I can reproduce this on Arch in a Gnome Wayland session too. It's as if the apps try to use wayland, but fail for some reason. Setting DISPLAY=:0 successfully redirects them to Xwayland though and ones that I tried start correctly.

I don't know much about apps being clients to a wayland compositor but if you can, try to open a topic at https://forum.snapcraft.io/ there should be some folks with actual hands-on knowledge of wayland who may be able to debug this further.

Comment 7 Maciek Borzecki 2020-10-07 06:17:56 UTC
Some additional information was collected here:
https://gitlab.gnome.org/GNOME/mutter/-/issues/1454
https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1897224

Looks like a problem is related to mutter, where it no longer exposes an abstract socket for Xwayland. The GNOME bug tracker report contains more details.

Comment 8 Ben Cotton 2021-11-04 17:28:20 UTC
This message is a reminder that Fedora 33 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 33 on 2021-11-30.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '33'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 33 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 9 Ben Cotton 2021-11-30 16:28:36 UTC
Fedora 33 changed to end-of-life (EOL) status on 2021-11-30. Fedora 33 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.