Bug 1883675 - segfault at start with Qt 5.15 + LTO enabled
Summary: segfault at start with Qt 5.15 + LTO enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texworks
Version: 33
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Robin Lee
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1882953 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-29 20:12 UTC by Real Name
Modified: 2020-10-05 00:15 UTC (History)
3 users (show)

Fixed In Version: texworks-0.6.5-6.fc33
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-05 00:15:31 UTC
Type: Bug


Attachments (Terms of Use)
include QPainterPath for Qt 5.15 (287 bytes, patch)
2020-09-29 20:12 UTC, Real Name
no flags Details | Diff

Description Real Name 2020-09-29 20:12:17 UTC
Created attachment 1717633 [details]
include QPainterPath for Qt 5.15

Description of problem:
TexWorks segfaults at start due to it being built with LTO enabled. Rebuilding it from source package fails because it's not fully compatible with Qt 5.15.


Version-Release number of selected component (if applicable):
texworks-0.6.5-5.fc33.x86_64

How reproducible:
always


Steps to Reproduce:
1. Install package
2. Try to run TexWorks
3. It doesn't start, ABRT intercepts the crash

Actual results:
TexWorks segfaults at start


Expected results:
TexWorks should start normally


Additional info:
Attaching a simple patch to make it build with Qt 5.15 (not fully tested though), not addressing the warnings for now. Must also %define _lto_cflags %{nil} in the spec file.

Comment 1 Fedora Update System 2020-09-30 09:20:56 UTC
FEDORA-2020-9c9f73bc69 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-9c9f73bc69

Comment 2 Qiyu Yan 2020-09-30 09:23:35 UTC
*** Bug 1882953 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2020-10-01 01:18:38 UTC
FEDORA-2020-9c9f73bc69 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-9c9f73bc69`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9c9f73bc69

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-10-05 00:15:31 UTC
FEDORA-2020-9c9f73bc69 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.