Bug 188368 - DVD install crashes on upgrade of FC4 at first copy to HD; repartition hangs befor formatting
DVD install crashes on upgrade of FC4 at first copy to HD; repartition hangs ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
http://jkbeard.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 12:24 EDT by James K Beard
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 13:50:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback dump on crash (138.38 KB, text/plain)
2006-04-08 12:24 EDT, James K Beard
no flags Details

  None (edit)
Description James K Beard 2006-04-08 12:24:02 EDT
Description of problem:
"Routine" upgrade of FC4 using FC5 DVS crashes at first copy of core to HD;
message says disk is probably full (it's far from full, has >100 GB free space).
 I have a anacdump.txt file that I will attach or include.

Installation that allows repartition hangs right after parititioning but before
formatting.  I allowed it to stay that way overnight in case I was just
impatient.  Computer does not respond to keyboard or on/off switch; reset button
must be used to regain control.  Rescue, fdisk works fine.

Version-Release number of selected component (if applicable):
FC5 DVD for x86_64

How reproducible:
Endlessly on one of my machines.  No problem on another with identical
configuration.  One big red flag:  HD of problem machine originally had Windows
XP 64-Bit Edition on it, and FC4 had trouble partitioning it.

Steps to Reproduce:
1.  Insert DVD for FC5 x86_64 and boot to it.
2.  Select Upgrade Existing Installation.
3.  Allow it to write anacdump.txt to floppy when it crashes trying to copy the
installation files to the HD.

Alternatively, select Delete Partitions and Use Default Configuration and it
will hang right after it writes the partition table, but before formatting.
  
Actual results:
Re-installed FC4, then upgraded without incident.

Expected results:
Trouble-free installation without problems or issues; this was seen about a week
earlier in a machine with identical hardware (AMD Athalon 64 4400+ X2 (dual
core), 2 GB RAM (passes RAM test).

Additional info:
Comment 1 James K Beard 2006-04-08 12:24:03 EDT
Created attachment 127509 [details]
Anaconda traceback dump on crash
Comment 2 Chris Lumens 2006-04-12 13:50:42 EDT
Looks like there was a problem reading part of stage2.img (part of anaconda)
from your DVD drive, as shown by these messages in your exception traceback:

<4>hda: media error (bad sector): status=0x51 { DriveReady SeekComplete Error }
<4>hda: media error (bad sector): error=0x34 { AbortedCommand LastFailedSense=0x03 }
<4>ide: failed opcode was: unknown
<4>end_request: I/O error, dev hda, sector 117832
<3>Buffer I/O error on device hda, logical block 29458

The error message you got about being out of space is just because some of our
error messages aren't set up to catch all these cases correctly.  We've done a
little work along these lines since FC5, so error messages should be more useful
now.

Note You need to log in before you can comment on or make changes to this bug.