Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1883681 - [abrt] gnome-calendar: on_calendar_monitor_completed_cb(): gnome-calendar killed by SIGABRT
Summary: [abrt] gnome-calendar: on_calendar_monitor_completed_cb(): gnome-calendar kil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-calendar
Version: 33
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:774e75e519e48b0b8e6e9562ea8...
: 1882876 1887340 1887983 1898706 1913334 (view as bug list)
Depends On:
Blocks: F33FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2020-09-29 20:27 UTC by Andrew Thurman
Modified: 2021-04-02 10:05 UTC (History)
13 users (show)

Fixed In Version: gnome-calendar-3.38.1-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-14 00:42:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (57.97 KB, text/plain)
2020-09-29 20:27 UTC, Andrew Thurman
no flags Details
File: core_backtrace (28.48 KB, text/plain)
2020-09-29 20:27 UTC, Andrew Thurman
no flags Details
File: cpuinfo (2.43 KB, text/plain)
2020-09-29 20:27 UTC, Andrew Thurman
no flags Details
File: dso_list (9.86 KB, text/plain)
2020-09-29 20:27 UTC, Andrew Thurman
no flags Details
File: environ (1.13 KB, text/plain)
2020-09-29 20:27 UTC, Andrew Thurman
no flags Details
File: limits (1.29 KB, text/plain)
2020-09-29 20:27 UTC, Andrew Thurman
no flags Details
File: maps (63.89 KB, text/plain)
2020-09-29 20:28 UTC, Andrew Thurman
no flags Details
File: mountinfo (2.93 KB, text/plain)
2020-09-29 20:28 UTC, Andrew Thurman
no flags Details
File: open_fds (2.43 KB, text/plain)
2020-09-29 20:28 UTC, Andrew Thurman
no flags Details
File: proc_pid_status (1.33 KB, text/plain)
2020-09-29 20:28 UTC, Andrew Thurman
no flags Details
File: var_log_messages (8.21 KB, text/plain)
2020-09-29 20:28 UTC, Andrew Thurman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-calendar - issues 647 0 None None None 2020-10-12 17:32:33 UTC

Description Andrew Thurman 2020-09-29 20:27:52 UTC
Description of problem:
Open calender app on Fedora 33 Beta.

Version-Release number of selected component:
gnome-calendar-3.38.0-1.fc33

Additional info:
reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Calendar@0.service
cmdline:        /usr/bin/gnome-calendar --gapplication-service
crash_function: on_calendar_monitor_completed_cb
executable:     /usr/bin/gnome-calendar
journald_cursor: s=9b14ade8a9584682b7020ee5c2240988;i=8e05;b=8a7d00853dd0485a890117b254379461;m=a651c26;t=5b07961277cc4;x=f383f19d230cea69
kernel:         5.8.12-300.fc33.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Andrew Thurman 2020-09-29 20:27:54 UTC
Created attachment 1717640 [details]
File: backtrace

Comment 2 Andrew Thurman 2020-09-29 20:27:56 UTC
Created attachment 1717641 [details]
File: core_backtrace

Comment 3 Andrew Thurman 2020-09-29 20:27:56 UTC
Created attachment 1717642 [details]
File: cpuinfo

Comment 4 Andrew Thurman 2020-09-29 20:27:57 UTC
Created attachment 1717643 [details]
File: dso_list

Comment 5 Andrew Thurman 2020-09-29 20:27:58 UTC
Created attachment 1717644 [details]
File: environ

Comment 6 Andrew Thurman 2020-09-29 20:27:59 UTC
Created attachment 1717645 [details]
File: limits

Comment 7 Andrew Thurman 2020-09-29 20:28:00 UTC
Created attachment 1717646 [details]
File: maps

Comment 8 Andrew Thurman 2020-09-29 20:28:01 UTC
Created attachment 1717647 [details]
File: mountinfo

Comment 9 Andrew Thurman 2020-09-29 20:28:02 UTC
Created attachment 1717648 [details]
File: open_fds

Comment 10 Andrew Thurman 2020-09-29 20:28:03 UTC
Created attachment 1717649 [details]
File: proc_pid_status

Comment 11 Andrew Thurman 2020-09-29 20:28:04 UTC
Created attachment 1717650 [details]
File: var_log_messages

Comment 12 Peter Simonyi 2020-10-09 05:54:10 UTC
Similar problem has been detected:

This happens every second time I launch Gnome Calendar, so I'd guess the application service might be the problem:

1. Start Calendar.  It opens fine.
2. Wait a moment, then close the window.
3. Start Calendar again.  This time, the window appears briefly and disappears.
(goto step 1)

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Calendar@0.service
cmdline:        /usr/bin/gnome-calendar --gapplication-service
crash_function: on_calendar_monitor_completed_cb
executable:     /usr/bin/gnome-calendar
journald_cursor: s=318e52e318de4dc78121695534b4194a;i=6619;b=c4b07725d8c14d5896a14ccfd5d58948;m=3c37c20;t=5b13565343b62;x=43de285df90f2ccf
kernel:         5.8.13-300.fc33.x86_64
package:        gnome-calendar-3.38.1-1.fc33
reason:         gnome-calendar killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 13 Fedora Blocker Bugs Application 2020-10-09 06:07:11 UTC
Proposed as a Blocker for 33-final by Fedora user psimonyi using the blocker tracking app because:

 "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test."

Crashing every second time you launch it seems like failing a basic functionality test.  Plus, since Calendar replaced Evolution in the default favourites list, it's a pretty prominent app.

Comment 14 Kamil Páral 2020-10-09 12:52:47 UTC
Similar problem has been detected:

Trying to reproduce bug 1883681. Started gnome-calendar twice, the second time it immediately crashed.

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Calendar@0.service
cmdline:        /usr/bin/gnome-calendar --gapplication-service
crash_function: on_calendar_monitor_completed_cb
executable:     /usr/bin/gnome-calendar
journald_cursor: s=ddad73e6f4e2402aaffe791469682569;i=2ee47f;b=7c261537394f4d169971a59cd1761dfe;m=26be36c3;t=5b13bf2a59f09;x=7d194b7afddf4e5b
kernel:         5.8.14-300.fc33.x86_64
package:        gnome-calendar-3.38.1-1.fc33
reason:         gnome-calendar killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000
xsession_errors:

Comment 15 Peter Simonyi 2020-10-09 14:56:58 UTC
Hm, I also get the same crash switching years (e.g. try to show next January) so perhaps this is related to upstream's https://gitlab.gnome.org/GNOME/gnome-calendar/-/merge_requests/149 and https://gitlab.gnome.org/GNOME/gnome-calendar/-/issues/647

Comment 16 Adam Williamson 2020-10-09 22:55:56 UTC
We have +4 blocker in the ticket, marking accepted.

Comment 17 Kamil Páral 2020-10-12 07:46:51 UTC
(In reply to Adam Williamson from comment #16)
> We have +4 blocker in the ticket, marking accepted.

Ticket link:
https://pagure.io/fedora-qa/blocker-review/issue/156

Comment 18 phnevsa 2020-10-12 07:52:06 UTC
*** Bug 1887340 has been marked as a duplicate of this bug. ***

Comment 19 Adam Williamson 2020-10-12 17:32:34 UTC
Peter: backtrace here is indeed the same as the one in https://gitlab.gnome.org/GNOME/gnome-calendar/-/merge_requests/149 , yeah. Good spot. Setting POST as there's a PR, though there is a possible issue with it so we probably can't just blindly backport it: "Decrementing the completed calendars counter was introduced by 78cb11c6 to fix #625, so you'd have to make sure it doesn't regress that bug."

Comment 20 bjoern.daase 2020-10-13 16:06:47 UTC
*** Bug 1882876 has been marked as a duplicate of this bug. ***

Comment 21 Michael Catanzaro 2020-10-13 16:54:00 UTC
I'll take this.

Comment 22 Fedora Update System 2020-10-13 17:59:04 UTC
FEDORA-2020-b973a3525f has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b973a3525f

Comment 23 Boricua 2020-10-13 18:09:33 UTC
*** Bug 1887983 has been marked as a duplicate of this bug. ***

Comment 24 Peter Simonyi 2020-10-13 19:17:02 UTC
Thanks, Michael.  That seems to fix it.

Comment 25 Fedora Update System 2020-10-13 22:39:46 UTC
FEDORA-2020-b973a3525f has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b973a3525f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b973a3525f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 26 Fedora Update System 2020-10-14 00:42:29 UTC
FEDORA-2020-b973a3525f has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 27 Boricua 2020-10-14 08:12:22 UTC
I tried the update several times and experienced one crash, on the second try.

Comment 28 Kamil Páral 2020-10-14 08:43:22 UTC
Boricua, have you rebooted after applying that update?

Comment 29 Boricua 2020-10-14 09:41:49 UTC
(In reply to Kamil Páral from comment #28)
> Boricua, have you rebooted after applying that update?

No. I did several logouts and have being launching the app without further crashes. I followed your suggestion and made a reboot. So far, no further issues.

Comment 30 Kamil Páral 2020-10-14 10:28:42 UTC
Then I assume the crash you encountered shortly after the update was still the old process running. (Next time, it's recommended to fully reboot after testing any update, in order to get fully reliable results).

Comment 31 Boricua 2020-10-14 12:00:02 UTC
Understood; thanks for the tip. I have been opening the app to the point of abuse, with no crash so far.

Comment 32 Andrew Thurman 2020-10-14 13:24:41 UTC
Seems to have fixed all problems with initial report. Thanks for the quick work guys!

Comment 33 Michael Catanzaro 2020-10-14 13:57:08 UTC
(In reply to Kamil Páral from comment #30)
> Then I assume the crash you encountered shortly after the update was still
> the old process running. (Next time, it's recommended to fully reboot after
> testing any update, in order to get fully reliable results).

I think logout should be enough to kill gnome-calendar. My guess is it was probably just some different crash. Anyway, feel free to get a backtrace (either with ABRT or coredumpctl) and post for analysis.

Comment 34 tothaa 2020-11-17 22:01:04 UTC
*** Bug 1898706 has been marked as a duplicate of this bug. ***

Comment 35 seb 2021-01-06 14:31:32 UTC
*** Bug 1913334 has been marked as a duplicate of this bug. ***

Comment 36 bendem 2021-04-02 10:05:17 UTC
Similar problem has been detected:

Removed a source file from $HOME/.config/evolution/sources because everything was duplicated.

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/app.slice/dbus-:1.2-org.gnome.Calendar@0.service
cmdline:        /usr/bin/gnome-calendar --gapplication-service
crash_function: on_calendar_monitor_completed_cb
executable:     /usr/bin/gnome-calendar
journald_cursor: s=ce495bd557d944e69dc649bc66d0e654;i=4a85;b=d02db40b60be4e7a80515be4fc044177;m=3c4fee809d;t=5bef99cf06643;x=3ff8a35a22402761
kernel:         5.11.10-200.fc33.x86_64
package:        gnome-calendar-3.38.2-1.fc33
reason:         gnome-calendar killed by SIGABRT
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000


Note You need to log in before you can comment on or make changes to this bug.