Bug 188370 - compat-wxGTK conflicts with wxGTK
compat-wxGTK conflicts with wxGTK
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compat-wxGTK (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 197025 (view as bug list)
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-04-08 13:15 EDT by Adam Pribyl
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.4.2-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-22 17:26:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2006-04-08 13:15:27 EDT
Description of problem:
Triing latest update I came to 
Transaction Check Error:   file /usr/share/locale/cs/LC_MESSAGES/wxstd.mo confli
cts between attempted installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6
.2-5.fc5
etc.
Both installed from extras.

Version-Release number of selected component (if applicable):
2.4.2-17
2.6.2-5

How reproducible:
always

Steps to Reproduce:
1. try to install compat-wxGTK and wxGTK at the same time
2.
3.
  
Actual results:
Conflict

Expected results:
Both installed as both are required by some application.

Additional info:
Comment 1 Michael Schwendt 2006-05-28 07:42:36 EDT
Hmmm... seems the 'RPM silently overwrites files "feature"' has been back
some time ago:

$ rpm -V wxGTK compat-wxGTK-common
S.5....T    /usr/share/locale/cs/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/da/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/de/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/es/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/fi/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/fr/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/hu/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/id/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/it/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/nl/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/pl/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/ru/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/sl/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/sv/LC_MESSAGES/wxstd.mo
S.5....T    /usr/share/locale/tr/LC_MESSAGES/wxstd.mo

$ rpm -qi wxGTK compat-wxGTK-common | grep Inst
Install Date: Wed 19 Apr 2006 12:58:46 PM CEST      Build Host:
hammer3.fedora.redhat.com
Install Date: Mon 20 Mar 2006 12:06:48 PM CET      Build Host:
hammer1.fedora.redhat.com
Comment 2 Danny Yee 2006-06-01 19:38:55 EDT
I hit this trying to "yum -y upgrade" from FC4 to FC5.  Everything ran fine -
lots of packages downloaded - but when I woke up it had barfed on this conflict.
 The annoying thing was that when I removed compat-wxGTK (I think I need it for
something, but I'll worry about that later) and reran "yum -y upgrade" it had to
download all the extras packages again.  Aaarrggh.
Comment 3 Michael Schwendt 2006-07-07 18:56:17 EDT
*** Bug 197025 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Miller 2006-07-07 20:58:55 EDT
So, uh, is it okay to solve this by removing localization for the compat
package? Just asking.....
Comment 5 Matthew Miller 2006-07-08 14:53:13 EDT
FWIW, as far as I can see, the only packages in FE-devel which still require
this are audacity-1.2.4-0.1.b.fc6 and nomadsync-0.4.2-12.fc5.
Comment 6 Matthew Miller 2006-07-08 14:56:27 EDT
Bug for updating audacity: bug #186819. Seems stuck.

Nomadsync is not developed further, according to upstream, and what's more,
"NomadSync must be compiled with a non-UNICODE version of wxGTK 2.4.2." That's
not very encouraging.
Comment 7 Jeff Silverman 2006-08-05 04:38:47 EDT
I ran into this problem, and here's how I dealt with it.  I got the RPM files
from  RepoView
http://download.fedora.redhat.com/pub/fedora/linux/extras/5/i386/compat-wxGTK-common-2.4.2-17.fc5.i386.rpm

http://download.fedora.redhat.com/pub/fedora/linux/extras/5/i386/compat-wxGTK-2.4.2-17.fc5.i386.rpm
and
http://download.fedora.redhat.com/pub/fedora/linux/extras/5/i386/wxGTK-2.6.3-2.6.3.2.2.fc5.i386.rpm
then used rpm to update them.

[root@black ~]# rpm -Uvh /home/jeffs/compat-wxGTK-2.4.2-17.fc5.i386.rpm
/home/jeffs/compat-wxGTK-common-2.4.2-17.fc5.i386.rpm
/home/jeffs/wxGTK-2.6.3-2.6.3.2.2.fc5.i386.rpm
Preparing...                ########################################### [100%]
        file /usr/share/locale/cs/LC_MESSAGES/wxstd.mo conflicts between
attempted installs of wxGTK-2.6.3-2.6.3.2.2.fc5 and compat-wxGTK-common-2.4.2-17.fc5
        ...
        file /usr/share/locale/tr/LC_MESSAGES/wxstd.mo conflicts between
attempted installs of wxGTK-2.6.3-2.6.3.2.2.fc5 and compat-wxGTK-common-2.4.2-17.fc5

Use rpm with the --replacefiles switch to update them.

[root@black ~]# rpm -Uvh --replacefiles
/home/jeffs/compat-wxGTK-2.4.2-17.fc5.i386.rpm
/home/jeffs/compat-wxGTK-common-2.4.2-17.fc5.i386.rpm
/home/jeffs/wxGTK-2.6.3-2.6.3.2.2.fc5.i386.rpm
Preparing...                ########################################### [100%]
   1:compat-wxGTK-common    ########################################### [ 33%]
   2:compat-wxGTK           ########################################### [ 67%]
/sbin/ldconfig: /usr/X11R6/lib/libXm.so.2 is not a symbolic link

   3:wxGTK                  ########################################### [100%]
[root@black ~]# rpm -q compat-wxGTK compat-wxGTK-common wxGTK
compat-wxGTK-2.4.2-17.fc5
compat-wxGTK-common-2.4.2-17.fc5
wxGTK-2.6.3-2.6.3.2.2.fc5
[root@black ~]#                     
Comment 8 Tom "spot" Callaway 2006-08-07 08:49:57 EDT
The problem with this workaround is that while it gets the packages installed,
it is not a valid fix. The translation files are not identical between wxGTK and
compat-wxGTK. Which set is more important? I'll probably end up renaming the
compat-wxGTK .mo files, but even that's not a very good fix.
Comment 9 Jeff Silverman 2006-08-07 15:44:16 EDT
I understand your objection.  I made a kludge.

The problem I was having is that the problem we are discussing was stopping the
update of the rest of the packages, and yum seems to be unable to restart an
aborted update.  Or if it can be done, it isn't obvious to me how to do it - do
you know?  I tried using the --exclude switches and that caused even more
problems.  I deleted the package from my system and I got dependency failures.

Sincerely yours,


Jeff Silverman
Comment 10 Konstantin Antselovich 2006-08-19 05:50:26 EDT
the same problem here

yum install compat-wxGTK compat-wxGTK-common wxGTK
...
(1/3): compat-wxGTK-2.4.2 100% |=========================| 1.7 MB    00:02
(2/3): wxGTK-2.6.3-2.6.3. 100% |=========================| 3.5 MB    00:05
(3/3): compat-wxGTK-commo 100% |=========================| 516 kB    00:00
Running Transaction Test
Finished Transaction Test


Transaction Check Error:   file /usr/share/locale/cs/LC_MESSAGES/wxstd.mo
conflicts between attempted installs of compat-wxGTK-common-2.4.2-17.fc5 and
wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/da/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/de/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/es/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/fi/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/fr/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/hu/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/id/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/it/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/nl/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/pl/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/ru/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/sl/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/sv/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
  file /usr/share/locale/tr/LC_MESSAGES/wxstd.mo conflicts between attempted
installs of compat-wxGTK-common-2.4.2-17.fc5 and wxGTK-2.6.3-2.6.3.2.2.fc5
Comment 11 Tom "spot" Callaway 2006-08-22 17:26:10 EDT
-19 renames the translation (.mo) files to compat-wxstd.mo. This should resolve
the conflict.

Note You need to log in before you can comment on or make changes to this bug.