Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1883701 - IngressController CRD's "scale" subresource was removed
Summary: IngressController CRD's "scale" subresource was removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Miciah Dashiel Butler Masters
QA Contact: Arvind iyengar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-29 22:28 UTC by Miciah Dashiel Butler Masters
Modified: 2020-10-27 16:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift api pull 756 0 None closed Bug 1883701: operator/ingress: Restore scale subresource 2020-11-09 02:07:51 UTC
Github openshift cluster-ingress-operator pull 469 0 None closed Bug 1883701: Bump openshift/api 2020-11-09 02:07:51 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:46:51 UTC

Description Miciah Dashiel Butler Masters 2020-09-29 22:28:00 UTC
Description of problem:

Recently, CRDs in openshift/api were migrated from version apiextensions.k8s.io/v1beta1 to apiextensions.k8s.io/v1.  In the process, the IngressController's "scale" subresource was inadvertently removed.


Version-Release number of selected component (if applicable):

The erroneous CRD is not in current builds, but the problem can be reproduced by directly applying the CRD from Git.


How reproducible:

Easily.


Steps to Reproduce:

1. Launch a cluster.

2. Apply the current IngressController CRD from Git:

    oc apply -f https://raw.githubusercontent.com/openshift/api/master/operator/v1/0000_50_ingress-operator_00-ingresscontroller.crd.yaml

3. Try to scale the default ingresscontroller:

    oc -n openshift-ingress-operator scale ingresscontroller/default --replicas=2


Actual results:

The `oc scale` command prints the following error message:

    Error from server (NotFound): ingresscontrollers.operator.openshift.io "default" not found


Expected results:

The `oc scale` command should print the following output:

    ingresscontroller.operator.openshift.io/default scaled


Additional info:

This commit mistakenly removed the IngressController CRD's "scale" subresource:  https://github.com/openshift/api/pull/720/commits/fdbff4bcb56c5263cc7b8a740a3684ca9f4ba116#diff-c43b8f4ae306bf7ac8fbdde984579af1L16-L19

Comment 1 Miciah Dashiel Butler Masters 2020-09-29 22:30:48 UTC
If possible, I would like to get this fixed in time to bump https://github.com/openshift/cluster-ingress-operator to use the updated CRD for 4.6.  However, I do not believe this is a release blocker if the fix does not merge in time.

Comment 2 W. Trevor King 2020-09-29 22:39:20 UTC
Retargeting to 4.6.0 to help land the PR.  If it misses code-freeze, we can move this back to 4.7.0.

Comment 5 Arvind iyengar 2020-10-05 09:01:17 UTC
The PR merged and made into "4.6.0-0.nightly-2020-10-01-012547". The error is no more seen during scaling of controller with the latest CRD in  place.

Comment 8 errata-xmlrpc 2020-10-27 16:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.