Bug 188373 - Cervisia takes over Nautilus mime type
Cervisia takes over Nautilus mime type
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 14:05 EDT by Luke Hutchison
Modified: 2008-01-27 21:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 21:44:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Hutchison 2006-04-08 14:05:23 EDT
Description of problem:
I use GNOME as my default desktop on FC5.  Recently I installed kdevelop, which
pulled in kdesdk and hence cervisia.  Now all my GNOME launchers that have a
file:// URI open Cervisia.  /usr/share/applications/kde/cervisia.desktop
 has the line "MimeType=inode/directory", which seems to be doing it.  This
doesn't seem to be a desirable thing to have happen during an install...
Comment 1 Andrew Ziem 2006-05-13 15:39:49 EDT
Cervisia breaks shortcuts in the GNOME panel: Home, Desktop, Connect to Server,
etc.  Also, it's not possible to use Run (ALT+F2) and enter any path.

This hack solves the problem:
chmod -x /usr/share/applications/kde/cervisia.desktop
Comment 2 Andy Fraser 2006-06-08 14:12:11 EDT
That hack doesn't work for me. I solved it by editing
.local/share/applications/mimeinfo.cache but this doesn't take peramanently.
Properties -> Open With doesn't work (I can't change the selection) and I can't
find another way to do this and make it stick.
Comment 3 Andrew 2006-08-16 15:26:34 EDT
Another solution may be specify the default application for the file type in
defaults.list (I haven't tried it):

http://www.gnome.org/learn/admin-guide/2.14/mimetypes-registering.html
Comment 4 Luke Hutchison 2006-08-17 09:11:02 EDT
You mean Nautilus should be registered to always handle inode/directory by
default?  That would probably do it.

Comment 5 Rex Dieter 2007-11-17 18:01:23 EST
Thank you for the bug report. However, Fedora Project no longer maintains this
 version of the product. Please upgrade to the latest version and open a new bug
 if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.