Bug 1883817 - [4.4.3-6] - in restore flow the hosted engine failed with "Cannot move Virtual Disk. The operation is not supported for HOSTED_ENGINE disks" [NEEDINFO]
Summary: [4.4.3-6] - in restore flow the hosted engine failed with "Cannot move Virtua...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-ansible-collection
Classification: oVirt
Component: General
Version: 1.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.4.3-1
: ---
Assignee: Martin Necas
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On: 1883446
Blocks: 1879995
TreeView+ depends on / blocked
 
Reported: 2020-09-30 10:18 UTC by Kobi Hakimi
Modified: 2020-11-11 06:41 UTC (History)
12 users (show)

Fixed In Version: ovirt-ansible-collection-1.2.0-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-11 06:41:44 UTC
oVirt Team: Infra
sbonazzo: needinfo? (mnecas)
pm-rhel: ovirt-4.4+
mtessun: blocker+
pm-rhel: planning_ack+
mperina: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-ansible-collection pull 135 0 None closed ovirt_disk: dont move disk when already in storage_domain 2021-01-10 18:55:13 UTC
Github oVirt ovirt-ansible-collection pull 162 0 None closed ovirt_disk: ignore moving of hosted engine disks 2021-01-10 18:55:15 UTC

Comment 2 Kobi Hakimi 2020-09-30 10:33:24 UTC
we had the same issue in 4.4.2-8

Comment 3 Asaf Rachmani 2020-10-01 07:42:04 UTC
It's probably related to some changes in ovirt_disk module.
Martin, can you please have a look?

Comment 4 Avihai 2020-10-01 10:43:06 UTC
This blocks testing for upgrade 4.3->4.4 flow, can you please give this higher priority?

Comment 5 Martin Necas 2020-10-05 14:15:08 UTC
It looks like module was trying to move the disk to same storage domain I added check which disables this.

Comment 7 RHEL Program Management 2020-10-20 12:58:25 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 10 Martin Perina 2020-10-23 08:03:50 UTC
Do we have any simpler reproduced other than this super complicated HE flow? Which flow exactly is called using ovirt_disk module?

Comment 11 Martin Perina 2020-10-23 08:10:51 UTC
That looks like RESTAPI error and ovirt_disk usually just translates the input and calls RESTAPI, so are we really requesting a valid flow?

Cannot move Virtual Disk. The operation is not supported for HOSTED_ENGINE disks.

Comment 12 Kobi Hakimi 2020-10-25 08:44:50 UTC
(In reply to Martin Perina from comment #10)
> Do we have any simpler reproduced other than this super complicated HE flow?
> Which flow exactly is called using ovirt_disk module?

We failed only in the restore flows which is complicate flow.
The rest simpler (deploy) flows we run successfully...

Comment 13 Asaf Rachmani 2020-10-25 09:44:28 UTC
(In reply to Martin Perina from comment #11)
> That looks like RESTAPI error and ovirt_disk usually just translates the
> input and calls RESTAPI, so are we really requesting a valid flow?
> 
> Cannot move Virtual Disk. The operation is not supported for HOSTED_ENGINE
> disks.

The flow hasn't changed and the restore works fine with the 'ovirt_disk_28' module, which has been removed in https://github.com/oVirt/ovirt-ansible-hosted-engine-setup/pull/372.

Comment 16 Sandro Bonazzola 2020-10-29 08:18:09 UTC
Can this move to modified?

Comment 18 Kobi Hakimi 2020-11-02 08:14:25 UTC
verified with build 4.4.3-12

Comment 19 Sandro Bonazzola 2020-11-11 06:41:44 UTC
This bugzilla is included in oVirt 4.4.3 release, published on November 10th 2020.

Since the problem described in this bug report should be resolved in oVirt 4.4.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.