Bug 1883826 - Misleading help texts in Helm install/upgrade forms
Summary: Misleading help texts in Helm install/upgrade forms
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-30 10:55 UTC by Rohit Rai
Modified: 2020-10-27 16:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:46:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6791 0 None closed Bug 1883826: Fix misleading help text and update helm empty state 2020-10-13 06:09:15 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:09 UTC

Description Rohit Rai 2020-09-30 10:55:29 UTC
Description of problem: The help text for the yaml editor of helm install form says `The Helm chart can be installed by manually entering YAML or JSON definitions, or by dragging and dropping a file into the editor.` but there's no support for file drop in the yaml editor. This can be misleading. Also the alert on form view needs to be generic to handle all use cases.
Prerequisites (if any, like setup, operators/versions):
Steps to Reproduce

    go to helm install form
    change to yaml view and check the help text.

Actual results: The help text says `The Helm chart can be installed by manually entering YAML or JSON definitions, or by dragging and dropping a file into the editor.`
Expected results: It should say `The Helm chart can be installed by manually entering YAML or JSON definitions.`
Reproducibility (Always/Intermittent/Only Once): Always
Build Details:
Additional info:

Comment 2 Abhinandan Das 2020-10-01 14:04:58 UTC
verified on 
OpenShift Version: 4.6.0-0.nightly-2020-10-01-012547
Kubernetes Version: v1.19.0+beb741b
Channel: stable-4.6
Cluster ID: 0da135ba-161e-4865-b243-e5307e5a4921
API Server: https://api.jakumar-01101215.devcluster.openshift.com:6443

Comment 5 errata-xmlrpc 2020-10-27 16:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.