Bug 188385 - PAM does not lift IrDA devices to console permission status
PAM does not lift IrDA devices to console permission status
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-08 17:22 EDT by Linus Walleij
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: pam-0.99.4.0-fc5.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 07:35:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Walleij 2006-04-08 17:22:12 EDT
Description of problem:

If you have e.g. a laptop with an IrDA (infrared) interface and
modprobe in a driver and then the TTY IrDA emulator, the resulting
terminal connections in /dev/ircomm0, /dev/ircomm1 ... etc
are not accessible by the console user. These are analogous
to USB sticks, memory cards etc and are used for e.g. accessing
mobile phones.

Version-Release number of selected component (if applicable):

pam-0.99.3.0-2

How reproducible:

Always.

Steps to Reproduce:
1. modprobe an IrDA driver (I use smsc-ircc2)
2. modprobe ircomm-tty
3. Resulting devices are not accessible by the cosole user
  
Actual results:

Not accessible by console user.

Expected results:

Should be accessible by console user.

Additional info:

I think adding these entries in the right places to 
/etc/security/console.perms.d/50-default.perms
should suffice:

<ircomm>=/dev/ircomm*

<console>  0600 <ircomm>     0600 root

I marked the severity as high since there are many people
that want to use their mobile phones over IrDA.
Comment 1 Linus Walleij 2006-07-25 17:35:20 EDT
Ping, anybody out there?
Comment 2 Tomas Mraz 2006-08-01 07:35:29 EDT
This was fixed in pam-0.99.4.0-fc5.4 - in FC5 updates.

Note You need to log in before you can comment on or make changes to this bug.