Bug 1883851 - When unsupported version of guest agent is installed, user see a wrong info message
Summary: When unsupported version of guest agent is installed, user see a wrong info m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-30 12:04 UTC by Yaacov Zamir
Modified: 2020-10-27 16:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:46:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6793 0 None closed Bug 1883851: Alert users about unsupported guest agent version 2020-12-16 07:56:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:09 UTC

Description Yaacov Zamir 2020-09-30 12:04:45 UTC
Description of problem:
When an unsupported version of guest agent is installed, kubevirt may or may not send guest agent information. User needs to know that the reason for missing information may be an unsupported version and not just missing guest agent.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a vm with an unsuported guest agent data.
   before creating the VM you can change the:
   supported-guest-agent field in the kubevirt-config config map.
2. check the VM detauls page
3.

Actual results:
A message saying guest agent is not installed.

Expected results:
A message saying guest is installed with wrong version number.

Additional info:
Sometimes kubevirt will get data from an supported versions, acting like it's a supported version, and sometimes not, acting like ga is not installed.

Comment 3 Guohua Ouyang 2020-10-12 02:45:58 UTC
It shows below message when unsupported version of the guest agent is installed.

"This VM has an unsupported version of the guest agent. When an unsupported version of a guest agent is installed, some management features are unavailable and the metrics might be inaccurate. Check with your system adminstartor for supported guest agent versions."

Comment 5 errata-xmlrpc 2020-10-27 16:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.