Bug 1883896 - Redfish virtual media not working with sushy-tools in dev-scripts
Summary: Redfish virtual media not working with sushy-tools in dev-scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.6
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Dmitry Tantsur
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-30 13:23 UTC by Stephen Benjamin
Modified: 2020-10-27 16:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
sushy-tools logs (6.95 MB, text/plain)
2020-09-30 13:25 UTC, Stephen Benjamin
no flags Details
ironic logs (806.72 KB, application/gzip)
2020-09-30 13:26 UTC, Stephen Benjamin
no flags Details
conductor log (927.32 KB, application/gzip)
2020-09-30 13:27 UTC, Stephen Benjamin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github metal3-io metal3-dev-env pull 495 0 None closed Bump sushy-tools to include a fix for potential race 2021-02-02 12:24:36 UTC
OpenStack gerrit 755297 0 None MERGED Handle race conditions when creating a directory for PersistentDict 2021-02-02 12:24:35 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:22 UTC

Description Stephen Benjamin 2020-09-30 13:23:58 UTC
Description of problem:

Trying to use dev-scripts with virtual media, ironic has the nodes stuck in enroll with the error "Failed to get power state for node 8896be72-2a21-429e-a0ea-e6d196fa0bfe. Error: HTTP GET http://192.168.111.1:8000/redfish/v1/Systems/19e67c5c-18bf-46dc-b990-1ecd183695a2 returned code 500. Base.1.0.GeneralError: Dict is not yet persistent"


Version-Release number of selected component (if applicable):

4.6 latest ci builds

How reproducible:

Always

Steps to Reproduce:
1. Create a new dev-scripts deployment with:

export PROVISIONING_NETWORK_PROFILE="Disabled"
export IP_STACK="v4"


2. Run make


Actual results:

See nodes get stuff in enroll/verifiying forever

Expected results:

Nodes get provisioned


Additional info:


sushy-tools reports:


[root@stbenjam-dfw2-m2 dev-scripts]# curl http://192.168.111.1:8000/redfish/v1/Systems/19e67c5c-18bf-46dc-b990-1ecd183695a2
{
  "error": {
    "code": "Base.1.0.GeneralError",
    "message": "Dict is not yet persistent",
    "@Message.ExtendedInfo": [
      {
        "@odata.type": "/redfish/v1/$metadata#Message.1.0.0.Message",
        "MessageId": "Base.1.0.GeneralError"
      }
    ]
  }
}

Comment 1 Stephen Benjamin 2020-09-30 13:25:50 UTC
Created attachment 1717875 [details]
sushy-tools logs

Comment 2 Stephen Benjamin 2020-09-30 13:26:46 UTC
Created attachment 1717876 [details]
ironic logs

gzipped because they're too large

Comment 3 Stephen Benjamin 2020-09-30 13:27:39 UTC
Created attachment 1717877 [details]
conductor log

Comment 4 Stephen Benjamin 2020-09-30 13:28:18 UTC
This is affecting the e2e-metal-ipi-virtualmedia CI job. To help pinpoint what happened, this started failing around 9/6.

Comment 8 Stephen Benjamin 2020-10-01 13:26:38 UTC
Fixes have landed. Hopefully we'll see the impact on CI soon.

Comment 12 errata-xmlrpc 2020-10-27 16:47:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.