Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1883903 - SDN's kube-rbac-proxy may fail becuase the kube-proxy is not ready
Summary: SDN's kube-rbac-proxy may fail becuase the kube-proxy is not ready
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Juan Luis de Sousa-Valadas
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-30 13:38 UTC by Juan Luis de Sousa-Valadas
Modified: 2020-10-27 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 786 0 None open Bug 1883903:Add retries to SDN's RBAC proxy 2020-09-30 13:38:44 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:22 UTC

Description Juan Luis de Sousa-Valadas 2020-09-30 13:38:07 UTC
Description of problem:
When starting a cluster we can see the kube-rbac-proxy failing because it's unable to reach kubernetes.default.svc.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Intermittent

Steps to Reproduce:
1. Create a new cluster
2. Look for restarts of SDN pods on openshift-sdn namespace


Actual results:
Sometimes the service is not available yet causing some restarts

Expected results:
We should retry for a while before failing.


Additional info:

Comment 2 Weibin Liang 2020-10-01 18:28:25 UTC
After installing several new clusters, does not see any Traceback for kube-proxy.

Talked with @valadas, it's very difficult to reproduce this bug.

QE verify this bug now and will re open it if we see the same issue in the future.

Comment 5 errata-xmlrpc 2020-10-27 16:47:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.