Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1883918 - Multiple Notifications for Available Updates in the Notification Drawer
Summary: Multiple Notifications for Available Updates in the Notification Drawer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Joe Caiani
QA Contact: Yanping Zhang
URL:
Whiteboard:
: 1883919 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-30 13:55 UTC by Megan Hall
Modified: 2020-10-27 16:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:47:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Image of the notification duplication in the drawer. (304.65 KB, image/png)
2020-09-30 13:55 UTC, Megan Hall
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6786 0 None closed Bug 1883918: Proposed fix for duplicate UpdateAvailable notifications in the notification drawer 2020-10-07 07:13:37 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:47:22 UTC

Description Megan Hall 2020-09-30 13:55:30 UTC
Created attachment 1717881 [details]
Image of the notification duplication in the drawer.

Description of problem:
There are currently 2 notifications in the notification drawer communicating to users that an update is available. One is in the format of an alert and the other is in the format of a recommendation. 

Version-Release number of selected component (if applicable):


How reproducible:
When there is an available update.

Steps to Reproduce:
1. When an update is available open the notification drawer and there will be one informational notification under the 'other' category and one recommendation under 'recommendation' category.

Actual results:
There are two notifications in the drawer.

Expected results:
One notification in the drawer.

Additional info:
For now, to remain in line with the monitoring team's best practices regarding alerts/notifications in the console, would be for this type of notification to remain as a recommendation.

Comment 1 Megan Hall 2020-09-30 13:58:54 UTC
*** Bug 1883919 has been marked as a duplicate of this bug. ***

Comment 4 Yanping Zhang 2020-10-09 08:04:55 UTC
Checked on 4.6 cluster with payload 4.6.0-0.nightly-2020-10-08-210814.
When there is new payload for upgrade, check in the notification drawer, there is only one message for upgrade in "Recommendations" part.
The bug is fixed, so move it to Verified.

Comment 6 errata-xmlrpc 2020-10-27 16:47:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.