Bug 1884006 - Hits Sync uses only old proxy setting
Summary: Hits Sync uses only old proxy setting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: RH Cloud - Inventory
Version: 6.8.0
Hardware: Unspecified
OS: Unspecified
high
unspecified vote
Target Milestone: 6.7.5
Assignee: Shimon Shtein
QA Contact: Mirek Długosz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-30 18:17 UTC by James Jeffers
Modified: 2020-10-26 19:03 UTC (History)
3 users (show)

Fixed In Version: tfm-rubygem-foreman_rh_cloud-1.0.12
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1874422
Environment:
Last Closed: 2020-10-26 19:03:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4346 0 None None None 2020-10-26 19:03:24 UTC

Description James Jeffers 2020-09-30 18:17:41 UTC
+++ This bug was initially created as a clone of Bug #1874422 +++

Inventory upload uses new proxy setting (Settings -> Content -> Default HTTP Proxy) by default; if it's not present, it will fall back to old setting (Settings -> General -> HTTP(S) proxy).

Insights hits sync (Configure -> Insights) uses only old setting. New proxy setting is ignored.

All network-related functionality in plugin should use the same algorithm for picking proxy - try new setting by default, and fall back to old if it's not present.


Found on:
pulp-server-2.21.2-1.el7sat.noarch
foreman-2.1.2.1-1.el7sat.noarch
katello-3.16.0-0.4.rc4.el7sat.noarch
satellite-6.8.0-1.el7sat.noarch
tfm-rubygem-foreman_rh_cloud-2.0.10-1.el7sat.noarch

--- Additional comment from  on 2020-09-01T15:01:11Z 

Same problem in "Sync inventory status" (Configure -> Inventory upload). It only uses old setting, new proxy setting is ignored by this action.

--- Additional comment from  on 2020-09-03T12:37:26Z 

*** Bug 1874417 has been marked as a duplicate of this bug. ***

Comment 2 Mirek Długosz 2020-10-12 16:47:53 UTC
New proxy setting is used by default. If it is not set, plugin falls back to old proxy setting. If it is not set either, proxy is not used.
Same proxy-selection algorithm is used for all network-related operations in plugin - inventory upload, hits sync and hosts status sync.


Tested on:
Satellite 6.7.5 snap 1
foreman-1.24.1.31-1.el7sat.noarch
katello-3.14.0-6.el7sat.noarch
pulp-server-2.21.0.4-1.el7sat.noarch
satellite-6.7.5-1.el7sat.noarch
tfm-rubygem-foreman_rh_cloud-1.0.12-1.el7sat.noarch

Comment 7 errata-xmlrpc 2020-10-26 19:03:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Satellite 6.7.5 Async Bug Fix Update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4346


Note You need to log in before you can comment on or make changes to this bug.