Bug 188405 - system hangs upon shut down, while shutting down eth0
system hangs upon shut down, while shutting down eth0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-09 02:10 EDT by Kevin Verma
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 19:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Verma 2006-04-09 02:10:16 EDT
Description of problem:
shutting down of interface eth0 hangs the system endlessly upon shutdown, in
case when ifcfg-eth0 is "ONBOOT=no"

Version-Release number of selected component (if applicable):
initscripts-8.31.1-1

How reproducible:
Very often

Steps to Reproduce:
1. edit ifcfg-eth0 using $EDITOR or system-config-network to manage eth0 not to
get active upon boot-up. 

2. Shutdown system once 

3. Boot up system 

4. Shut down again

  
Actual results:
system hangs while shutting down eth0

Expected results:
a clean system shutdown

Additional info:
Comment 1 Kevin Verma 2006-04-09 07:53:15 EDT
Since NetworkManager is working well for me and I do not want to see [failed]
messages without any particular reason on startup I decide to keep extra
interfaces disabled on startup.

I have just responded to a post on fc-list with simillar problem, I hope thst
will provide more peer review, if they follow-up us here.

Futher in an another town I had setup a FC5 system for a known and there I
applied the same thought in setup to disable non-required interfaces at startup,
while one being eth0. I did tested that it never hanged on shutdown.

I gave a call to that person again, and learnt that he is using that FC5 setup
instead of windows everyday so far without any problems and the system is
shutting down without any problems. 

I need to farily try ahead to reproduce the problem, but I am so scarred of
killing my hdd. My further doubt is on the chipsets. The chipset that I am
having on my system is well popular: 
Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller (rev 81) and the
kernel module being used is "e100" along "mii"
Comment 2 Bill Nottingham 2006-04-10 11:30:38 EDT
What happens if you try the updates-testing initscripts?
Comment 3 Kevin Verma 2006-10-02 15:26:50 EDT
Sorry for a very late follow up, this issue seems to have got fixed for me over
the period by some updates of initscripts. Thanks, and you might like to close
this bug. 
Comment 4 Bill Nottingham 2006-10-02 19:56:26 EDT
Thanks, closing.

Note You need to log in before you can comment on or make changes to this bug.