Bug 188412 - The following requested languages could not be built: ada
The following requested languages could not be built: ada
Status: CLOSED DUPLICATE of bug 187853
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-09 05:47 EDT by Axel Thimm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-10 05:02:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2006-04-09 05:47:46 EDT
Description of problem:
Similar to bug 188411 I wanted to rebuild the rawhide version of gcc on FC5. It
fails during configure with

+ ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
--enable-shared --enable-threads=posix --enable-checking=release
--with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions
--enable-libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada
--enable-java-awt=gtk --disable-dssi
--with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --with-cpu=generic
--host=x86_64-redhat-linux
creating cache ./config.cache
checking host system type... x86_64-redhat-linux-gnu
checking target system type... x86_64-redhat-linux-gnu
checking build system type... x86_64-redhat-linux-gnu
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln works... yes
checking whether ln -s works... yes
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -g -pipe -Wall -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -mtune=generic ) works... yes
checking whether the C compiler (gcc -O2 -g -pipe -Wall -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -mtune=generic ) is a
cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for gnatbind... gnatbind
checking whether compiler driver understands Ada... no
checking how to compare bootstrapped objects... cmp --ignore-initial=16 $$f1 $$f2
checking for correct version of gmp.h... yes
checking for MPFR... yes
configure: error: 
The following requested languages could not be built: ada
Recognised languages are: c,ada,c++,fortran,java,objc,obj-c++,treelang
error: Bad exit status from /var/tmp/rpm-tmp.9569 (%build)


Version-Release number of selected component (if applicable):
gcc-4.1.0-3 building gcc-4.1.0-6

How reproducible:
always

Steps to Reproduce:
1.rpmbuild --rebuild gcc-4.1.0-6.src.rpm
Comment 1 Jakub Jelinek 2006-04-10 05:02:06 EDT

*** This bug has been marked as a duplicate of 187853 ***

Note You need to log in before you can comment on or make changes to this bug.