Bug 188416 - generated httpd.conf not suitable for apache 2.2
generated httpd.conf not suitable for apache 2.2
Status: CLOSED DUPLICATE of bug 180056
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
http://httpd.apache.org/docs/2.2/upgr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-09 06:49 EDT by Andy Burns
Modified: 2015-03-04 20:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-09 07:48:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Burns 2006-04-09 06:49:22 EDT
Description of problem:
I had edited httpd.conf by hand and it was working, I then edited it using
s-c-httpd, I accepted that my changes would be overwritten, however the file
produced has LoadModule directives in it which are only suitable for 2.0 not 2.2

Version-Release number of selected component (if applicable):
1.3.3-1.1

How reproducible:
100%

Steps to Reproduce:
1. use s-c-httpd to edit httpd.conf
2. apachectl-restart
  
Actual results:
apache refuses to restart due to "missing" modules

Expected results:
valid httpd.conf file

Additional info:
between apache 2.0 and 2.2 several modules were changed, particularly for
authentication e.g. mod_access.so is now mod_authz_host.so
Comment 1 Andy Burns 2006-04-09 06:54:14 EDT
A list of modules affectes can be found at
http://httpd.apache.org/docs/2.2/upgrading.html
Comment 2 Ignacio Vazquez-Abrams 2006-04-09 07:48:03 EDT

*** This bug has been marked as a duplicate of 180056 ***

Note You need to log in before you can comment on or make changes to this bug.