Bug 188417 - During install - i686 kernel picked for i586 system
During install - i686 kernel picked for i586 system
Status: CLOSED DUPLICATE of bug 186378
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-04-09 07:45 EDT by Maarten van Leunen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-05 04:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Maarten van Leunen 2006-04-09 07:45:45 EDT
Description of problem:
When attempting to install Fedora Core 5 on my Toshiba Libretto L5 through
PXE-NetBoot, the installation process proceeds fine, until the actual
'installing packages'

The message dialog on the install screen:
There was an error running your transaction, for the following reason(s):
package for incorrect arch.

The message on the error-log:
error running transaction: package <packagename> is intended for a i686 architecture

The following packages are indicated for <packagename>:

I'm attempting an install of:
bordeaux-DVD-i386/FC-5-i386-DVD.iso (loop-device mounted on an NFS share.)

My Toshiba Libretto L5 has the following specs:
- Transmeta Crusoe Chip, 800 Mhz (i586 compatible)
- 256 Mb memory
- 20 Gb Ide HD

Version-Release number of selected component (if applicable):
Fedora Core 5

How reproducible:

Steps to Reproduce:
1. generic install a i586 computer with the DVD FC5 iso.
Actual results:
Installation is aborted with the message provided in the description. Upon
pressing "OK" the machine reboots.

Expected results:
A fully installed i586 machine with Fedora Core 5.

Additional info:
Comment 1 Jason Tibbitts 2006-04-24 16:12:45 EDT
I have exactly the opposite problem: I've done six or so installs so far and
every one of them has installed the i586 kernel when the i686 (or SMP i686)
kernel should have been installed instead.  Fortunately in my case the machine
actually boots and I can install the proper kernel.

I'm able to recompile anaconda and rebuild the boot media in order to test any
patches or extract any additional debug info.
Comment 2 Maarten van Leunen 2006-05-05 04:57:36 EDT

*** This bug has been marked as a duplicate of 186378 ***

Note You need to log in before you can comment on or make changes to this bug.