Bug 1884231 - ssh-copy-id fails due to shell incompatibility
Summary: ssh-copy-id fails due to shell incompatibility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 33
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1885336 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-01 12:09 UTC by Georg Müller
Modified: 2020-10-23 22:04 UTC (History)
11 users (show)

Fixed In Version: openssh-8.4p1-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-23 22:04:44 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openssh openssh-portable pull 206/ 0 None None None 2020-10-06 07:25:05 UTC

Description Georg Müller 2020-10-01 12:09:21 UTC
Description of problem:


Version-Release number of selected component (if applicable):
openssh-8.4p1-1.1.fc33.x86_64

How reproducible:


Steps to Reproduce:
1. ssh-copy-id to-some-host

Actual results:
/usr/bin/ssh-copy-id: INFO: attempting to log in with the new key(s), to filter out any that are already installed
/usr/bin/ssh-copy-id: INFO: 1 key(s) remain to be installed -- if you are prompted now it is to install the new keys
/usr/bin/ssh-copy-id: line 251: warning: here-document at line 251 delimited by end-of-file (wanted `EOF')
/usr/bin/ssh-copy-id: line 250: warning: here-document at line 250 delimited by end-of-file (wanted `EOF')
/usr/bin/ssh-copy-id: line 254: /dev/null`: Permission denied
/usr/bin/ssh-copy-id: line 260: EOF: command not found
password:

After giving the password, it states that the key is added, but nothing happened.

Expected results:
* no shell errors
* key is copied

Additional info:
This is a simple parenthesis at the wrong place. Simply moving the closing parenthesis behind the EOF marker solves the issue.
There is a pull request upstream to fix the issue.:
https://github.com/openssh/openssh-portable/pull/206/files

Comment 1 Glenn Johnson 2020-10-01 14:08:38 UTC
Identical experience for me, Fedora 33 Mate Beta.

Comment 2 Jakub Jelen 2020-10-01 16:11:07 UTC
Thank you for the report. I will fix it as soon as we will have final fix upstream.

Comment 3 Jakub Jelen 2020-10-06 07:25:38 UTC
*** Bug 1885336 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2020-10-06 14:00:27 UTC
FEDORA-2020-f623ad8e4c has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f623ad8e4c

Comment 5 Fedora Update System 2020-10-06 15:19:04 UTC
FEDORA-2020-f623ad8e4c has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f623ad8e4c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f623ad8e4c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-10-23 22:04:44 UTC
FEDORA-2020-f623ad8e4c has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.